Spreadsheet function categories

Database functions

Date and time functions

Engineering functions

Financial functions

Information functions

Logical functions

Lookup and reference functions

Math and trigonometry functions

Statistical functions

Text functions

Database functions

When you need to analyze whether values in a list meet a specific condition, you can use a database spreadsheet function. For example, in a list that contains sales information, you can count all the rows or records in which the sales are greater than 1,000 but less than 2,500.

Some database and list management spreadsheet functions have names that begin with the letter "D." These functions, also known as Dfunctions, have three arguments — database, field, and criteria.

  • The database argument is the range that contains your list. You must include the row that contains the column labels in the range.

  • The field argument is the label for the column you want to summarize.

  • The criteria argument is the range that contains a condition you specify.

Which function do you want to read about?

DAVERAGE spreadsheet function

DCOUNT spreadsheet function

DCOUNTA spreadsheet function

DGET spreadsheet function

DMAX spreadsheet function

DMIN spreadsheet function

DPRODUCT spreadsheet function

DSTDEV spreadsheet function

DSTDEVP spreadsheet function

DSUM spreadsheet function

DVAR spreadsheet function

DVARP spreadsheet function

Return to top

Date and time functions

With date and time functions, you can analyze and work with date and time values in formulas. For example, if you need to use the current date in a formula, use the TODAY spreadsheet function, which returns the current date based on your computer's system clock.

Which function do you want to read about?

DATE spreadsheet function

DATEVALUE spreadsheet function

DAY spreadsheet function

DAYS360 spreadsheet function

EDATE spreadsheet function

EOMONTH spreadsheet function

HOUR spreadsheet function

MINUTE spreadsheet function

MONTH spreadsheet function

NETWORKDAYS spreadsheet function

NOW spreadsheet function

SECOND spreadsheet function

TIME spreadsheet function

TIMEVALUE spreadsheet function

TODAY spreadsheet function

WEEKDAY spreadsheet function

WORKDAY spreadsheet function

YEAR spreadsheet function

YEARFRAC spreadsheet function

Return to top

Engineering functions

The engineering spreadsheet functions perform engineering analysis. Most of these functions are of three types:

  • Functions for working with complex numbers

  • Functions for converting values between different numbering systems, such as decimal, hexadecimal, octal, and binary systems

  • Functions for converting values between different systems of measurement

Note The engineering functions are provided through a separate dynamic link library file, Msowcf.dll. If this file is missing, the functions display the #NAME? error value when you open the spreadsheet in your browser. Search for Msowcf.dll on your computer, and if it's missing, either reinstall Microsoft Office 2000 or contact your system administrator.

Which function do you want to read about?

BESSELI spreadsheet function

BESSELJ spreadsheet function

BESSELK spreadsheet function

BESSELY spreadsheet function

BIN2DEC spreadsheet function

BIN2HEX spreadsheet function

BIN2OCT spreadsheet function

COMPLEX spreadsheet function

CONVERT spreadsheet function

DEC2BIN spreadsheet function

DEC2HEX spreadsheet function

DEC2OCT spreadsheet function

DELTA spreadsheet function

ERF spreadsheet function

ERFC spreadsheet function

GESTEP spreadsheet function

HEX2BIN spreadsheet function

HEX2DEC spreadsheet function

HEX2OCT spreadsheet function

IMABS spreadsheet function

IMAGINARY spreadsheet function

IMARGUMENT spreadsheet function

IMCONJUGATE spreadsheet function

IMCOS spreadsheet function

IMDIV spreadsheet function

IMEXP spreadsheet function

IMLN spreadsheet function

IMLOG10 spreadsheet function

IMLOG2 spreadsheet function

IMPOWER spreadsheet function

IMPRODUCT spreadsheet function

IMREAL spreadsheet function

IMSIN spreadsheet function

IMSQRT spreadsheet function

IMSUB spreadsheet function

IMSUM spreadsheet function

OCT2BIN spreadsheet function

OCT2DEC spreadsheet function

OCT2HEX spreadsheet function

Return to top

Financial functions

Financial functions perform common business calculations, such as determining the payment for a loan, the future value or net present value of an investment, and the values of bonds or coupons.

Common arguments for the financial functions include:

  • Future value (fv) — the value of the investment or loan after all payments have been made.

  • Number of periods (nper) — the total number of payments or periods of an investment.

  • Payment (pmt) — the amount paid periodically to an investment or loan.

  • Present value (pv) — the value of an investment or loan at the beginning of the investment period. For example, the present value of a loan is the principal amount that is borrowed.

  • Rate (rate) — the interest rate or discount rate for a loan or investment.

  • Type (type) — the interval at which payments are made during the payment period, such as at the beginning of a month or the end of the month.

Which function do you want to read about?

ACCRINT spreadsheet function

ACCRINTM spreadsheet function

AMORDEGRC spreadsheet function

AMORLINC spreadsheet function

COUPDAYBS spreadsheet function

COUPDAYS spreadsheet function

COUPDAYSNC spreadsheet function

COUPNCD spreadsheet function

COUPNUM spreadsheet function

COUPPCD spreadsheet function

CUMIPMT spreadsheet function

CUMPRINC spreadsheet function

DB spreadsheet function

DDB spreadsheet function

DISC spreadsheet function

DOLLARDE spreadsheet function

DOLLARFR spreadsheet function

DURATION spreadsheet function

EFFECT spreadsheet function

FV spreadsheet function

FVSCHEDULE spreadsheet function

INTRATE spreadsheet function

IPMT spreadsheet function

IRR spreadsheet function

MDURATION spreadsheet function

MIRR spreadsheet function

NOMINAL spreadsheet function

NPER spreadsheet function

NPV spreadsheet function

ODDFPRICE spreadsheet function

ODDFYIELD spreadsheet function

ODDLPRICE spreadsheet function

ODDLYIELD spreadsheet function

PMT spreadsheet function

PPMT spreadsheet function

PRICE spreadsheet function

PRICEDISC spreadsheet function

PRICEMAT spreadsheet function

PV spreadsheet function

RATE spreadsheet function

RECEIVED spreadsheet function

SLN spreadsheet function

SYD spreadsheet function

TBILLEQ spreadsheet function

TBILLPRICE spreadsheet function

TBILLYIELD spreadsheet function

VDB spreadsheet function

XIRR spreadsheet function

XNPV spreadsheet function

YIELD spreadsheet function

YIELDDISC spreadsheet function

YIELDMAT spreadsheet function

Return to top

Information functions

Use an information spreadsheet function to determine the type of data stored within a cell. The information functions include a group of spreadsheet functions known as the IS functions and return TRUE if the cell meets a condition. For example, if the cell contains an even value, the ISEVEN spreadsheet function returns TRUE. If you need to determine whether blank cells exist in a range of cells, you can use the COUNTBLANK spreadsheet function to count the number of blank cells in a range of cells, or you can use the ISBLANK spreadsheet function to determine whether one cell in the range is blank.

Which function do you want to read about?

CELL spreadsheet function

COUNTBLANK spreadsheet function

ERROR.TYPE spreadsheet function

ISBLANK spreadsheet function

ISERR spreadsheet function

ISERROR spreadsheet function

ISEVEN spreadsheet function

ISLOGICAL spreadsheet function

ISNA spreadsheet function

ISNONTEXT spreadsheet function

ISNUMBER spreadsheet function

ISODD spreadsheet function

ISREF spreadsheet function

ISTEXT spreadsheet function

N spreadsheet function

NA spreadsheet function

TYPE spreadsheet function

Return to top

Logical functions

You can use the logical functions either to see whether a condition is true or false or to check for multiple conditions. For example, you can use the IF function to determine whether a condition is true or false: One value is returned if the condition is true, and a different value is returned if the condition is false.

Which function do you want to read about?

AND spreadsheet function

FALSE spreadsheet function

IF spreadsheet function

NOT spreadsheet function

OR spreadsheet function

TRUE spreadsheet function

Return to top

Lookup and reference functions

When you need to find values in lists or tables or when you need to find the reference of a cell, you can use the lookup and reference spreadsheet functions. For example, to find a value in a table by matching a value in the first column of a table, use the VLOOKUP spreadsheet function. To determine the position of a value in a list, use the MATCH spreadsheet function.

Which function do you want to read about?

ADDRESS spreadsheet function

AREAS spreadsheet function

CHOOSE spreadsheet function

COLUMN spreadsheet function

COLUMNS spreadsheet function

HLOOKUP spreadsheet function

HYPERLINK spreadsheet function

INDEX spreadsheet function

INDIRECT spreadsheet function

LOOKUP spreadsheet function

MATCH spreadsheet function

OFFSET spreadsheet function

ROW spreadsheet function

ROWS spreadsheet function

VLOOKUP spreadsheet function

Return to top

Math and trigonometry functions

With math and trigonometry functions, you can perform simple calculations, such as rounding a number or calculating the total value for a range of cells, or complex calculations, such as calculating the total value for a range of cells that meet a condition in another range of cells.

Which function do you want to read about?

ABS spreadsheet function

ACOS spreadsheet function

ACOSH spreadsheet function

ASIN spreadsheet function

ASINH spreadsheet function

ATAN spreadsheet function

ATAN2 spreadsheet function

ATANH spreadsheet function

CEILING spreadsheet function

COMBIN spreadsheet function

COS spreadsheet function

COSH spreadsheet function

COUNTIF spreadsheet function

DEGREES spreadsheet function

EVEN spreadsheet function

EXP spreadsheet function

FACT spreadsheet function

FACTDOUBLE spreadsheet function

FLOOR spreadsheet function

GCD spreadsheet function

INT spreadsheet function

LCM spreadsheet function

LN spreadsheet function

LOG spreadsheet function

LOG10 spreadsheet function

MOD spreadsheet function

MROUND spreadsheet function

MULTINOMIAL spreadsheet function

ODD spreadsheet function

PI spreadsheet function

POWER spreadsheet function

PRODUCT spreadsheet function

QUOTIENT spreadsheet function

RADIANS spreadsheet function

RAND spreadsheet function

RANDBETWEEN spreadsheet function

ROMAN spreadsheet function

ROUND spreadsheet function

ROUNDDOWN spreadsheet function

ROUNDUP spreadsheet function

SERIESSUM spreadsheet function

SIGN spreadsheet function

SIN spreadsheet function

SINH spreadsheet function

SQRT spreadsheet function

SQRTPI spreadsheet function

SUBTOTAL spreadsheet function

SUM spreadsheet function

SUMIF spreadsheet function

SUMPRODUCT spreadsheet function

SUMSQ spreadsheet function

SUMX2MY2 spreadsheet function

SUMX2PY2 spreadsheet function

SUMXMY2 spreadsheet function

TAN spreadsheet function

TANH spreadsheet function

TRUNC spreadsheet function

Return to top

Statistical functions

Statistical spreadsheet functions perform statistical analysis on ranges of data. For example, a statistical spreadsheet function can provide statistical information about a straight line plotted through a group of values, such as the slope of the line and the y-intercept, or about the actual points that make up the straight line.

Which function do you want to read about?

AVEDEV spreadsheet function

AVERAGE spreadsheet function

AVERAGEA spreadsheet function

BETADIST spreadsheet function

BETAINV spreadsheet function

BINOMDIST spreadsheet function

CHIDIST spreadsheet function

CHIINV spreadsheet function

CHITEST spreadsheet function

CONFIDENCE spreadsheet function

CORREL spreadsheet function

COUNT spreadsheet function

COUNTA spreadsheet function

COVAR spreadsheet function

CRITBINOM spreadsheet function

DEVSQ spreadsheet function

EXPONDIST spreadsheet function

FDIST spreadsheet function

FINV spreadsheet function

FISHER spreadsheet function

FISHERINV spreadsheet function

FORECAST spreadsheet function

FTEST spreadsheet function

GAMMADIST spreadsheet function

GAMMAINV spreadsheet function

GAMMALN spreadsheet function

GEOMEAN spreadsheet function

HARMEAN spreadsheet function

HYPGEOMDIST spreadsheet function

INTERCEPT spreadsheet function

KURT spreadsheet function

LARGE spreadsheet function

LOGINV spreadsheet function

LOGNORMDIST spreadsheet function

MAX spreadsheet function

MAXA spreadsheet function

MEDIAN spreadsheet function

MIN spreadsheet function

MINA spreadsheet function

MODE spreadsheet function

NEGBINOMDIST spreadsheet function

NORMDIST spreadsheet function

NORMINV spreadsheet function

NORMSDIST spreadsheet function

NORMSINV spreadsheet function

PEARSON spreadsheet function

PERCENTILE spreadsheet function

PERCENTRANK spreadsheet function

PERMUT spreadsheet function

POISSON spreadsheet function

PROB spreadsheet function

QUARTILE spreadsheet function

RANK spreadsheet function

RSQ spreadsheet function

SKEW spreadsheet function

SLOPE spreadsheet function

SMALL spreadsheet function

STANDARDIZE spreadsheet function

STDEV spreadsheet function

STDEVA spreadsheet function

STDEVP spreadsheet function

STDEVPA spreadsheet function

STEYX spreadsheet function

TDIST spreadsheet function

TINV spreadsheet function

TRIMMEAN spreadsheet function

TTEST spreadsheet function

VAR spreadsheet function

VARA spreadsheet function

VARP spreadsheet function

VARPA spreadsheet function

WEIBULL spreadsheet function

ZTEST spreadsheet function

Return to top

Text functions

With text functions, you can manipulate text strings in formulas. For example, you can change the case or determine the length of a text string. You can also join, or concatenate, a date to a text string. The following formula is an example of how you can use the TODAY function with the TEXT function to create a message that contains the current date and formats the date in the "dd-mmm-yyyy" number format.

="Budget report as of "&TEXT(TODAY(),"dd-mmm-yyyy")

Which function do you want to read about?

CHAR spreadsheet function

CLEAN spreadsheet function

CODE spreadsheet function

CONCATENATE spreadsheet function

DOLLAR spreadsheet function

EXACT spreadsheet function

FIND spreadsheet function

FIXED spreadsheet function

LEFT spreadsheet function

LEN spreadsheet function

LOWER spreadsheet function

MID spreadsheet function

PROPER spreadsheet function

REPLACE spreadsheet function

REPT spreadsheet function

RIGHT spreadsheet function

SEARCH spreadsheet function

SUBSTITUTE spreadsheet function

T spreadsheet function

TEXT spreadsheet function

TRIM spreadsheet function

UPPER spreadsheet function

VALUE spreadsheet function

Return to top


Microsoft Excel worksheet functions not available in Web spreadsheets

The following Microsoft Excel functions are not available in spreadsheets published on the Web. If you publish a worksheet that contains one of these functions, the function is replaced with the resultant value of the function.

CALL | MDETERM
DATEDIF | MIDB
FINDB | MINVERSE
FREQUENCY | MMULT
GETPIVOTDATA | PHONETIC
GROWTH | REGISTER.ID
INFO | REPLACEB
ISPMT | RIGHTB
JIS | SEARCHB
LEFTB | SQL.REQUEST
LENB | TRANSPOSE
LINEST | TREND
LOGEST | YEN

In Excel, the INDEX and LOOKUP functions each have two forms, an array form and a non-array form. The array forms of these functions are not available in Web spreadsheets.


ABS

Returns the absolute value of a number, which is a number without its sign.

Syntax

ABS(number)

Number is the number whose absolute value you want.


ACCRINT

Returns the accrued interest for a security that pays periodic interest.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

ACCRINT(issue,first_interest,settlement,rate,par,frequency,basis)

Issue is the security's issue date.

First_interest is the security's first interest date.

Settlement is the security's settlement date: the date after the issue date when the security is traded to the buyer.

Rate is the security's annual coupon rate.

Par is the security's par value. If omitted, ACCRINT uses $1,000.

Frequency is the number of coupon payments per year. Annual payments = 1; semiannual = 2; quarterly = 4.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


ACCRINTM

Returns the accrued interest at maturity for a security that pays interest.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

ACCRINTM(issue,maturity,rate,par,basis)

Issue is the security's issue date.

Maturity is the security's maturity date: a number that represents the date when the security expires.

Rate is the security's annual coupon rate.

Par is the security's par value. If omitted, ACCRINT uses $1,000.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


ACOS

Returns the arccosine of a number, in radians in the range 0 to Pi. The arccosine is the angle whose cosine is Number.

Syntax

ACOS(number)

Number is the cosine of the angle you want and must be from -1 to 1.


ACOSH

Returns the inverse hyperbolic cosine of a number.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

ACOSH(number)

Number is any real number equal to or greater than 1.


ADDRESS

Creates a cell reference as text, given specified row and column numbers.

Syntax

ADDRESS(row_num,column_num,abs_num,a1,sheet_text)

Row_num is the row number to use in the cell reference: Row_num = 1 for row 1.

Column_num is the column number to use in the cell reference: Column_num = 4 for column D.

Abs_num specifies the reference type: absolute = 1; absolute row/relative column = 2; relative row/absolute column = 3; relative = 4.

A1 is a logical value that specifies the reference style. Because the Spreadsheet Component does not support R1C1 style, if you use this argument, the value must be 1, which represents A1 style. If a value other than 1 is used, ADDRESS returns the #VALUE! error value.

Sheet_text specifies the name of the sheet to be used in an external reference in Microsoft Excel workbooks, but not in spreadsheets on the Web. Because the Spreadsheet Component does not support external references, ADDRESS returns the #VALUE! error value if sheet_text is used.


AMORDEGRC

Returns the prorated linear depreciation of an asset for each accounting period by using a depreciation coefficient.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

AMORDEGRC(cost,date_purchased,first_period,salvage,period,rate,basis)

Cost is the cost of the asset.

Date_purchased is the date the asset was purchased.

First_period is the date of the end of the first accounting period.

Salvage is the salvage value at the end of the life of the asset.

Period is the accounting period.

Rate is the rate of depreciation.

Basis is a number that specifies the year basis: 360 days (NASD method) = 0; actual = 1; 365 days/year = 3; 360 days/year (European method) = 4.


AMORLINC

Returns the prorated linear depreciation of an asset for each accounting period.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

AMORLINC(cost,date_purchased,first_period,salvage,period,rate,basis)

Cost is the cost of the asset.

Date_purchased is the date the asset was purchased.

First_period is the date of the end of the first accounting period.

Salvage is the salvage value at the end of the life of the asset.

Period is the accounting period.

Rate is the rate of depreciation.

Basis is a number that specifies the year basis: 360 days (NASD method) = 0; actual = 1; 365 days/year = 3; 360 days/year (European method) = 4.


AND

Returns TRUE if all its arguments are TRUE; returns FALSE if any argument is FALSE.

Syntax

AND(logical1,logical2,...)

Logical1 Logical1, Logical2, ... are 1 to 30 conditions you want to test that can be either TRUE or FALSE and can be logical values or references.


AREAS

Returns the number of areas in a reference. An area is a range of contiguous cells or a single cell.

Syntax

AREAS(reference)

Reference is a reference to a cell or range of cells. If multiple areas are referenced, AREAS returns the #VALUE! error value.


ASIN

Returns the arcsine of a number in radians, in the range -Pi/2 to Pi/2.

Syntax

ASIN(number)

Number is the sine of the angle you want and must be from -1 to 1.


ASINH

Returns the inverse hyperbolic sine of a number.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

ASINH(number)

Number is any real number.


ATAN

Returns the arctangent of a number in radians, in the range -Pi/2 to Pi/2.

Syntax

ATAN(number)

Number is the tangent of the angle you want.


ATAN2

Returns the arctangent of the specified x- and y- coordinates, in radians between -Pi and Pi, excluding -Pi.

Syntax

ATAN2(x_num,y_num)

X_num is the x-coordinate of the point.

Y_num is the y-coordinate of the point.

Note If both x_num and y_num are 0 (zero), ATAN2 returns the #DIV/0! error value.


ATANH

Returns the inverse hyperbolic tangent of a number.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

ATANH(number)

Number is any real number between -1 and 1, excluding -1 and 1.


AVEDEV

Returns the average of the absolute deviations of data points from their mean. Arguments can be numbers, names, or references that contain numbers.

Syntax

AVEDEV(number1,number2,...)

Number1 Number1, Number2, ... are 1 to 30 arguments for which you want the average of the absolute deviations.


AVERAGE

Returns the average (arithmetic mean) of its arguments, which can be numbers, names, or references that contain numbers.

Syntax

AVERAGE(number1,number2,...)

Number1 Number1, Number2, ... are 1 to 30 numeric arguments for which you want the average.


AVERAGEA

Returns the average (arithmetic mean) of its arguments, evaluating text in arguments as 0, the logical value TRUE as 1, and the logical value FALSE as 0. Arguments can be numbers, names, or references.

Syntax

AVERAGEA(value1,value2,...)

Value1 Value1, Value2, ... are 1 to 30 arguments for which you want the average.


BESSELI

Returns the modified Bessel function In(x).

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

BESSELI(x,n)

X is the value at which to evaluate the function.

N is the order of the Bessel function. If N is not an integer, N is truncated.


BESSELJ

Returns the Bessel function Jn(x).

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

BESSELJ(x,n)

X is the value at which to evaluate the function.

N is the order of the Bessel function. If N is not an integer, N is truncated.


BESSELK

Returns the modified Bessel function Kn(x).

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

BESSELK(x,n)

X is the value at which to evaluate the function.

N is the order of the function. If N is not an integer, N is truncated.


BESSELY

Returns the Bessel function Yn(x), also called the Weber function or the Neumann function.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

BESSELY(x,n)

X is the value at which to evaluate the function.

N is the order of the function. If N is not an integer, N is truncated.


BETADIST

Returns the cumulative beta probability density function.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

BETADIST(x,alpha,beta,A,B)

X is the value between A and B at which to evaluate the function.

Alpha is a parameter to the distribution and must be greater than 0 (zero).

Beta is a parameter to the distribution and must be greater than 0.

A is an optional lower bound to the interval of x. If omitted, A = 0.

B is an optional upper bound to the interval of x. If omitted, B = 1.


BETAINV

Returns the inverse of the cumulative beta probability density function (BETADIST).

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

BETAINV(probability,alpha,beta,A,B)

Probability is a probability that is associated with the beta distribution.

Alpha is a parameter to the distribution and must be greater than 0 (zero).

Beta is a parameter to the distribution and must be greater than 0.

A is an optional lower bound to the interval of x. If omitted, A = 0.

B is an optional upper bound to the interval of x. If omitted, B = 1.


BIN2DEC

Converts a binary number to a decimal number.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

BIN2DEC(number)

Number is the binary number you want to convert, up to 10 characters. The most significant bit is the sign bit; use two's-complement notation for negative numbers.


BIN2HEX

Converts a binary number to a hexadecimal number.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

BIN2HEX(number,places)

Number is the binary number you want to convert, up to 10 characters. The most significant bit is the sign bit; use two's-complement notation for negative numbers.

Places is the number of characters to use. If omitted, uses the minimum number of characters necessary. Useful to pad with leading zeros.


BIN2OCT

Converts a binary number to an octal number.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

BIN2OCT(number,places)

Number is the binary number you want to convert, up to 10 characters. The most significant bit is the sign bit; use two's-complement notation for negative numbers.

Places is the number of characters to use. If omitted, uses the minimum number of characters necessary. Useful to pad with leading zeros.


BINOMDIST

Returns the individual term binomial distribution probability.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

BINOMDIST(number_s,trials,probability_s,cumulative)

Number_s is the number of successes in trials.

Trials is the number of independent trials.

Probability_s is the probability of success on each trial.

Cumulative is a logical value: for the cumulative distribution function, use TRUE; for the probability mass function, use FALSE.


CEILING

Rounds a number up to the nearest integer or to the nearest multiple of significance.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

CEILING(number,significance)

Number is the value you want to round up.

Significance is the multiple you want to round up to.


CELL

Returns information about the formatting, location, or contents of the upper-left cell in a reference.

Syntax

CELL(info_type,reference)

Info_type is a text string in quotation marks ("") that specifies the type of cell information you want.

Info type | Returns
"address" | Reference of the first cell in reference, as text.
"col" | Column number of the cell in reference.
"contents" | Contents of the upper-left cell in reference.
"prefix" | Text value corresponding to the "label prefix" of the cell. Returns single quotation mark (') if the cell contains left-aligned text, double quotation mark (") if the cell contains right-aligned text, caret (^) if the cell contains centered text, backslash (\) if the cell contains fill-aligned text, and empty text ("") if the cell contains anything else.
"protect" | 0 if the cell is not locked, and 1 if the cell is locked.
"row" | Row number of the cell in reference.
"type" | Text value corresponding to the type of data in the cell. Returns "b" for blank if the cell is empty, "l" for label if the cell contains a text constant, and "v" for value if the cell contains anything else.
"width" | Column width of the cell rounded off to an integer. Each unit of column width is equal to the width of one character in the default font size.

Reference is the cell you want information about. If omitted, CELL returns the #VALUE! error value.


CHAR

Returns the character specified by the code number from the character set for your computer.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

CHAR(number)

Number is a number between 1 and 255 that specifies the character you want.


CHIDIST

Returns the one-tailed probability of the chi-squared distribution.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

CHIDIST(x,deg_freedom)

X is the value at which you want to evaluate the distribution, which is a nonnegative number.

Deg_freedom is the number of degrees of freedom, a number between 1 and 10^10, excluding 10^10.


CHIINV

Returns the inverse of the one-tailed probability of the chi-squared distribution.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

CHIINV(probability,deg_freedom)

Probability is a probability associated with the chi-squared distribution, which is a value between 0 and 1 inclusive.

Deg_freedom is the number of degrees of freedom, a number between 1 and 10^10, excluding 10^10.


CHITEST

Returns the test for independence: the value from the chi-squared distribution for the statistic and the appropriate degrees of freedom.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

CHITEST(actual_range,expected_range)

Actual_range is the range of data that contains observations to test against expected values.

Expected_range is the range of data that contains the ratio of the product of row totals and column totals to the grand total.


CHOOSE

Chooses a value or action to perform from a list of values, based on an index number.

Syntax

CHOOSE(index_num,value1,value2,...)

Index_num Specifies which value argument is selected. Index_num must be between 1 and 29, or a formula or a reference to a number between 1 and 29.

Value1 Value1, Value2, ... are 1 to 29 numbers, cell references, formulas, functions, or text arguments that CHOOSE selects from.


CLEAN

Removes all nonprintable characters from a text string.

Syntax

CLEAN(text)

Text is a text string or a reference to cell that contains text from which you want to remove nonprintable characters.


CODE

Returns a numeric code for the first character in a text string, in the character set used by your computer.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

CODE(text)

Text is the text for which you want the code for the first character.


COLUMN

Returns the column number of a reference.

Syntax

COLUMN(reference)

Reference is the cell or range of contiguous cells whose column number you want. If omitted, the cell that contains the COLUMN function is used.


COLUMNS

Returns the number of columns in a reference.

Syntax

COLUMNS(array)

Array is a reference to a range of cells whose number of columns you want.


COMBIN

Returns the number of combinations for a given number of items.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

COMBIN(number,number_chosen)

Number is the total number of items.

Number_chosen is the number of items in each combination.


COMPLEX

Converts real and imaginary coefficients into a complex number of the form x + yi or x + yj.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

COMPLEX(real_num,i_num,suffix)

Real_num is the real coefficient of the complex number.

I_num is the imaginary coefficient of the complex number.

Suffix is the suffix for the imaginary component of the complex number, lowercase i or j. If omitted, Suffix = i is used.


CONCATENATE

Joins several text strings into one text string.

Syntax

CONCATENATE (text1,text2,...)

Text1 Text1, Text2, ... are 1 to 30 text strings to be joined into a single text string and can be text strings, numbers, or single-cell references.


CONFIDENCE

Returns the confidence interval for a population mean.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

CONFIDENCE(alpha,standard_dev,size)

Alpha is the significance level that is used to compute the confidence level, a number greater than 0 (zero) and less than 1.

Standard_dev is the population standard deviation for the data range and is assumed to be known. Standard_dev must be greater than 0.

Size is the sample size.


CONVERT

Converts a number from one measurement system to another, such as miles to kilometers.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

CONVERT(number,from_unit,to_unit)

Number is the value in From_unit to convert.

From_unit is a text value that specifies the units for Number.

To_unit is a text value that specifies the units for the result.


CORREL

Returns the correlation coefficient between two data sets.

Syntax

CORREL(array1,array2)

Array1 is a cell range of values. The values can be numbers or references that contain numbers.

Array2 is a second cell range of values. The values can be numbers or references that contain numbers.


COS

Returns the cosine of an angle.

Syntax

COS(number)

Number is the angle in radians whose cosine you want.


COSH

Returns the hyperbolic cosine of a number.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

COSH(number)

Number is any real number.


COUNT

Counts how many numbers and cells that contain numbers are in the list of arguments.

Syntax

COUNT(value1,value2,...)

Value1 Value1, Value2, ... are 1 to 30 arguments that can contain or refer to a variety of different types of data, but only numbers are counted.


COUNTA

Counts how many values and cells that are not empty are in the list of arguments.

Syntax

COUNTA(value1,value2,...)

Value1 Value1, Value2, ... are 1 to 30 arguments that represent the values and cells you want to count. Values can be any type of information.


COUNTBLANK

Counts empty cells in a specified range of cells.

Syntax

COUNTBLANK(range)

Range is the range from which you want to count the blank cells.


COUNTIF

Counts the number of cells within a range that meet the given criteria.

Syntax

COUNTIF(range,criteria)

Range is the range of cells whose nonblank cells you want to count.

Criteria is the criteria in the form of a number, expression, or text that defines which cells to count.


COUPDAYBS

Returns the number of days from the beginning of the coupon period to the settlement date for a security.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

COUPDAYBS(settlement,maturity,frequency,basis)

Settlement is the security's settlement date: the date after the issue date when the security is traded to the buyer.

Maturity is the security's maturity date: the date when the security expires.

Frequency is the number of coupon payments per year. Annual payments = 1; semiannual = 2; quarterly = 4.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


COUPDAYS

Returns the number of days in the coupon period that contains the settlement date for a security.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

COUPDAYS(settlement,maturity,frequency,basis)

Settlement is the security's settlement date: the date after the issue date when the security is traded to the buyer.

Maturity is the security's maturity date: the date when the security expires.

Frequency is the number of coupon payments per year. Annual payments = 1; semiannual = 2; quarterly = 4.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


COUPDAYSNC

Returns the number of days from the settlement date to the next coupon date for a security.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

COUPDAYSNC(settlement,maturity,frequency,basis)

Settlement is the security's settlement date: the date after the issue date when the security is traded to the buyer.

Maturity is the security's maturity date: the date when the security expires.

Frequency is the number of coupon payments per year. Annual payments = 1; semiannual = 2; quarterly = 4.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


COUPNCD

Returns a number that represents the next coupon date after the settlement date for a security.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

COUPNCD(settlement,maturity,frequency,basis)

Settlement is the security's settlement date: the date after the issue date when the security is traded to the buyer.

Maturity is the security's maturity date: the date when the security expires.

Frequency is the number of coupon payments per year. Annual payments = 1; semiannual = 2; quarterly = 4.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


COUPNUM

Returns the number of coupons payable between the settlement date and maturity date, rounded up to the nearest whole coupon.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

COUPNUM(settlement,maturity,frequency,basis)

Settlement is the security's settlement date: the date after the issue date when the security is traded to the buyer.

Maturity is the security's maturity date: the date when the security expires.

Frequency is the number of coupon payments per year. Annual payments = 1; semiannual = 2; quarterly = 4.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


COUPPCD

Returns a serial number that represents the previous coupon date before the settlement date for a security.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

COUPPCD(settlement,maturity,frequency,basis)

Settlement is the security's settlement date: the date after the issue date when the security is traded to the buyer.

Maturity is the security's maturity date: the date when the security expires.

Frequency is the number of coupon payments per year. Annual payments = 1; semiannual = 2; quarterly = 4.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


COVAR

Returns covariance, the average of the products of deviations for each data point pair in two data sets.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

COVAR(array1,array2)

Array1 is the first cell range of integers and must be numbers or references that contain numbers.

Array2 is the second cell range of integers and must be numbers or references that contain numbers.


CRITBINOM

Returns the smallest value for which the cumulative binomial distribution is greater than or equal to a criterion value.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

CRITBINOM(trials,probability_s,alpha)

Trials is the number of Bernoulli trials.

Probability_s is the probability of success on each trial, a number between 0 and 1 inclusive.

Alpha is the criterion value, a number between 0 and 1 inclusive.


CUMIPMT

Returns the cumulative interest paid on a loan between the starting and ending payment periods.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

CUMIPMT(rate,nper,pv,start_period,end_period,type)

Rate is the interest rate per period.

Nper is the total number of payment periods.

Pv is the present value, or the lump-sum amount that the series of future payments is worth now.

Start_period is the first period in the calculation. Payment periods are numbered beginning with 1.

End_period is the last period in the calculation.

Type is a logical value: payment at the beginning of the period = 1; payment at the end of the period = 0 or omitted.


CUMPRINC

Returns the cumulative principal paid on a loan between the starting and ending periods.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

CUMPRINC(rate,nper,pv,start_period,end_period,type)

Rate is the interest rate per period.

Nper is the total number of payment periods.

Pv is the present value, or the lump-sum amount that the series of future payments is worth now.

Start_period is the first period in the calculation. Payment periods are numbered beginning with 1.

End_period is the last period in the calculation.

Type is a logical value that represents the timing of payment: payment at the end of the period = 0; payment at the beginning of the period = 1.


DATE

Returns the serial number of a particular date.

Syntax

DATE(year,month,day)

Year is a number from 1900 to 9999.

Month is a number from 1 to 12 that represents the month of the year.

Day is a number from 1 to 31 that represents the day of the month.


DATEVALUE

Converts a date in the form of text to a serial number.

Syntax

DATEVALUE(date_text)

Date_text is text that represents a date in a date format, between 1/1/1900 and 12/31/9999.


DAVERAGE

Averages the values in a column in a list or database that match conditions you specify.

Syntax

DAVERAGE(database,field,criteria)

Database is the range of cells that makes up the list or database. A "database" is a list of related data.

Field is either the label of the column in double quotation marks or a number that represents the column's position in the list.

Criteria is the range of cells that contains the conditions you specify. The range includes a column label and one cell below the label for a condition.


DAY

Returns the day of the month (a number from 1 to 31) that corresponds to a serial number.

Syntax

DAY(serial_number)

Serial_number is a number that represents the date or text in date format, such as "4-1-1999" or "31-Oct-2000".


DAYS360

Returns the number of days between two dates based on a 360-day year (twelve 30-day months).

Syntax

DAYS360(start_date,end_date,method)

Start_date, End_date are the two dates you want to know the number of days between.

Method is a logical value that specifies the calculation method: U.S. (NASD) = FALSE or omitted; European = TRUE.


DB

Returns the depreciation of an asset for a specified period by using the fixed-declining balance method.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

DB(cost,salvage,life,period,month)

Cost is the initial cost of the asset.

Salvage is the salvage value at the end of the life of the asset.

Life is the number of periods over which the asset is being depreciated (sometimes called the useful life of the asset).

Period is the period for which you want to calculate the depreciation. Period must use the same units as Life.

Month is the number of months in the first year. If Month is omitted, the number is assumed to be 12.


DCOUNT

Counts the cells containing numbers in the field (column) of records in the database that match the conditions you specify.

Syntax

DCOUNT(database,field,criteria)

Database is the range of cells that makes up the list or database. A "database" is a list of related data.

Field is either the label of the column in double quotation marks or a number that represents the column's position in the list.

Criteria is the range of cells that contains the conditions you specify. The range includes a column label and at least one cell below the label for a condition.


DCOUNTA

Counts nonblank cells in the field (column) of records in the database that match the conditions you specify.

Syntax

DCOUNTA(database,field,criteria)

Database is the range of cells that makes up the list or database. A "database" is a list of related data.

Field is either the label of the column in double quotation marks or a number that represents the column's position in the list.

Criteria is the range of cells that contains the conditions you specify. The range includes a column label and at least one cell below the label for a condition.


DDB

Returns the depreciation of an asset for a specified period by using the double-declining balance method or some other method you specify.

Syntax

DDB(cost,salvage,life,period,factor)

Cost is the initial cost of the asset.

Salvage is the salvage value at the end of the life of the asset.

Life is the number of periods over which the asset is being depreciated (sometimes called the useful life of the asset).

Period is the period for which you want to calculate the depreciation. Period must use the same units as Life.

Factor is the rate at which the balance declines. If Factor is omitted, it is assumed to be 2 (the double-declining balance method).


DEC2BIN

Converts a decimal number to a binary number. Negative numbers are returned as 10-character (10-bit) binary numbers in two's-complement notation; the most significant bit is the sign bit.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

DEC2BIN(number,places)

Number is the decimal integer you want to convert.

Places is the number of characters to use. If omitted, uses the minimum number of characters necessary. Useful to pad with leading zeros.


DEC2HEX

Converts a decimal number to a hexadecimal number. Negative numbers are returned as 10-character (40-bit) hex numbers; the MSB is the sign bit.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

DEC2HEX(number,places)

Number is the decimal integer you want to convert.

Places is the number of characters to use. If omitted, uses the minimum number of characters necessary. Useful to pad with leading zeros.


DEC2OCT

Converts a decimal number to an octal number. Negative numbers are returned as 10-character (30-bit) binary numbers in two's-complement notation; the MSB is the sign bit.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

DEC2OCT(number,places)

Number is the decimal integer you want to convert.

Places is the number of characters to use. If omitted, uses the minimum number of characters necessary. Useful to pad with leading zeros.


DEGREES

Converts radians to degrees.

Syntax

DEGREES(angle)

Angle is the angle in radians that you want to convert.


DELTA

Tests whether two numbers are equal. Returns 1 if the first number is equal to the second number; or 0 (zero) if they are not equal.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

DELTA(number1,number2)

Number1 is the first number to test.

Number2 is the second number. If omitted, Number2 is assumed to be 0 (zero).


DEVSQ

Returns the sum of squares of deviations of data points from their sample mean.

Syntax

DEVSQ(number1,number2,...)

Number1 Number1, number2, ... are 1 to 30 numbers that you want DEVSQ to calculate.


DGET

Extracts from a database a single record that matches the conditions you specify.

Syntax

DGET(database,field,criteria)

Database is the range of cells that makes up the list or database. A "database" is a list of related data.

Field is either the label of the column in double quotation marks or a number that represents the column's position in the list.

Criteria is the range of cells that contains the conditions you specify. The range includes a column label and at least one cell below the label for a condition.


DISC

Returns the discount rate for a security.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

DISC(settlement,maturity,pr,redemption,basis)

Settlement is the security's settlement date: the date after the issue date when the security is traded to the buyer.

Maturity is the security's maturity date: the date when the security expires.

Pr is the security's price per $100 face value.

Redemption is the security's redemption value per $100 face value.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


DMAX

Returns the largest number in the field (column) of records in the database that match the conditions you specify.

Syntax

DMAX(database,field,criteria)

Database is the range of cells that makes up the list or database. A "database" is a list of related data.

Field is either the label of the column in double quotation marks or a number that represents the column's position in the list.

Criteria is the range of cells that contains the conditions you specify. The range includes a column label and at least one cell below the label for a condition.


DMIN

Returns the smallest number in the field (column) of records in the database that match the conditions you specify.

Syntax

DMIN(database,field,criteria)

Database is the range of cells that makes up the list or database. A "database" is a list of related data.

Field is either the label of the column in double quotation marks or a number that represents the column's position in the list.

Criteria is the range of cells that contains the conditions you specify. The range includes a column label and at least one cell below the label for a condition.


DOLLAR

Converts a number to text, using currency format.

Syntax

DOLLAR(number,decimals)

Number is a number, a reference to a cell containing a number, or a formula that evaluates to a number.

Decimals is the number of digits to the right of the decimal point. The number is rounded as necessary; if omitted, Decimals = 2.


DOLLARDE

Converts a dollar price expressed as a fraction into a dollar price expressed as a decimal number.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

DOLLARDE(fractional_dollar,fraction)

Fractional_dollar is a number expressed as a fraction.

Fraction is the integer to use in the denominator of the fraction.


DOLLARFR

Converts a dollar price expressed as a decimal number into a dollar price expressed as a fraction.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

DOLLARFR(decimal_dollar,fraction)

Decimal_dollar is a decimal number.

Fraction is the integer to use in the denominator of the fraction.


DPRODUCT

Multiplies the values in the field (column) of records in the database that match the conditions you specify.

Syntax

DPRODUCT(database,field,criteria)

Database is the range of cells that makes up the list or database. A "database" is a list of related data.

Field is either the label of the column in double quotation marks or a number that represents the column's position in the list.

Criteria is the range of cells that contains the conditions you specify. The range includes a column label and at least one cell below the label for a condition.


DSTDEV

Estimates the standard deviation based on a sample from selected database entries.

Syntax

DSTDEV(database,field,criteria)

Database is the range of cells that makes up the list or database. A "database" is a list of related data.

Field is either the label of the column in double quotation marks or a number that represents the column's position in the list.

Criteria is the range of cells that contains the conditions you specify. The range includes a column label and at least one cell below the label for a condition.


DSTDEVP

Calculates the standard deviation based on the entire population of selected database entries.

Syntax

DSTDEVP(database,field,criteria)

Database is the range of cells that makes up the list or database. A "database" is a list of related data.

Field is either the label of the column in double quotation marks or a number that represents the column's position in the list.

Criteria is the range of cells that contains the conditions you specify. The range includes a column label and at least one cell below the label for a condition.


DSUM

Adds the numbers in the field (column) of records in the database that match the conditions you specify.

Syntax

DSUM(database,field,criteria)

Database is the range of cells that makes up the list or database. A "database" is a list of related data.

Field is either the label of the column in double quotation marks or a number that represents the column's position in the list.

Criteria is the range of cells that contains the conditions you specify. The range includes a column label and at least one cell below the label for a condition.


DURATION

Returns the Macauley duration for an assumed par value of $100 for a security. Duration is the weighted average of the present value of the cash flows.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

DURATION(settlement,maturity,coupon,yld,frequency,basis)

Settlement is the security's settlement date: the date after the issue date when the security is traded to the buyer.

Maturity is the security's maturity date: the date when the security expires.

Coupon is the security's annual coupon rate.

Yld is the security's annual yield.

Frequency is the number of coupon payments per year. Annual payments = 1; semiannual = 2; quarterly = 4.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


DVAR

Estimates variance based on a sample from selected database entries.

Syntax

DVAR(database,field,criteria)

Database is the range of cells that makes up the list or database. A "database" is a list of related data.

Field is either the label of the column in double quotation marks or a number that represents the column's position in the list.

Criteria is the range of cells that contains the conditions you specify. The range includes a column label and at least one cell below the label for a condition.


DVARP

Calculates variance based on the entire population of selected database entries.

Syntax

DVARP(database,field,criteria)

Database is the range of cells that makes up the list or database. A "database" is a list of related data.

Field is either the label of the column in double quotation marks or a number that represents the column's position in the list.

Criteria is the range of cells that contains the conditions you specify. The range includes a column label and at least one cell below the label for a condition.


EDATE

Returns the serial number that represents the date that is the indicated number of months before or after a specified date.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

EDATE(start_date,months)

Start_date is a date from which to count forward or back a given number of months. The number of months is determined by Months.

Months is the number of months before or after Start_date, which is positive for a future date and negative for a past date.


EFFECT

Returns the effective annual interest rate, given the nominal rate and the number of compounding periods per year.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

EFFECT(nominal_rate,npery)

Nominal_rate is the nominal interest rate.

Npery is the number of compounding periods per year.


EOMONTH

Returns the serial number that represents the last day of the month that is the indicated number of months before or after a given date.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

EOMONTH(start_date,months)

Start_date is a date from which to count forward or back a given number of months. The number of months is determined by Months.

Months is the number of months before or after Start_date, which is positive for a future date and negative for a past date.


ERF

Returns the error function integrated between a lower limit and an upper limit.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

ERF(lower_limit,upper_limit)

Lower_limit is the lower bound for integrating ERF.

Upper_limit is the upper bound for integrating ERF. If omitted, ERF integrates between 0 (zero) and Lower_limit.


ERFC

Returns the complementary ERF function integrated between X and infinity.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

ERFC(x)

X is the lower bound for integrating ERF.


ERROR.TYPE

Returns a number that corresponds to one of the error values in the Spreadsheet Component.

Syntax

ERROR.TYPE(error_val)

Error_val can be an error value or a reference to a cell containing the error value.

If error_val is | ERROR.TYPE returns
#NULL! | 1
#DIV/0! | 2
#VALUE! | 3
#REF! | 4
#NAME? | 5
#NUM! | 6
#N/A | 7
#CIRC! | #CIRC!
Anything else | #N/A


EUROCONVERT

Converts a number to euros, converts a number from euros to a euro member currency, or converts a number from one euro member currency to another by using the euro as an intermediary (triangulation). The currencies available for conversion are those of European Union (EU) members that have adopted the euro. The function uses fixed conversion rates that are established by the EU.

Syntax

EUROCONVERT(number,source,target,full_precision,triangulation_precision)

Number is the currency value you want to convert, or a reference to a cell containing the value.

Source is a three-letter string, or reference to a cell containing the string, corresponding to the ISO code for the source currency. The following currency codes are available in the EUROCONVERT function:

Country | Basic unit of currency | ISO code
Belgium | franc | BEF
Luxembourg | franc | LUF
Germany | deutsche mark | DEM
Spain | peseta | ESP
France | franc | FRF
Ireland | pound | IEP
Italy | lira | ITL
Netherlands | guilder | NLG
Austria | schilling | ATS
Portugal | escudo | PTE
Finland | markka | FIM
Euro member states | euro | EUR

The following countries may adopt the euro after the initial version of EUROCONVERT, and if so, Microsoft will update the EUROCONVERT function. For information about new euro member currencies and updates to the EUROCONVERT function, connect to the Microsoft euro Web site.

Country | Basic unit of currency | ISO Code
Denmark | krone | DKK
Greece | drachma | GRD
Sweden | krona | SEK
UK | pound sterling | GBP

Target is a three-letter string, or cell reference, corresponding to the ISO code of the currency to which you want to convert the number. See the previous Source table for the ISO codes.

Full_precision is a logical value (TRUE or FALSE), or an expression that evaluates to a value of TRUE or FALSE, that specifies how to round the result.

Use | If you want the Spreadsheet Component to
FALSE | Use the currency-specific rounding rules, see the table that follows. The Spreadsheet Component uses the calculation precision value to calculate the result and the display precision value to display the result. FALSE is the default if the full_precision argument is omitted.
TRUE | Ignore the currency-specific rounding rules and instead use the six-significant-digit conversion factor with no follow-up rounding.

The following table shows the currency specific rounding rules, that is, how many decimal places the Spreadsheet Component uses to calculate a currency's conversion and display the result.

ISO code | Calculation precision | Display precision
BEF | 0 | 0
LUF | 0 | 0
DEM | 2 | 2
ESP | 0 | 0
FRF | 2 | 2
IEP | 2 | 2
ITL | 0 | 0
NLG | 2 | 2
ATS | 2 | 2
PTE | 1 | 2
FIM | 2 | 2
EUR | 2 | 2

Triangulation_precision is an integer equal to or greater than 3 that specifies the number of significant digits to be used for the intermediate euro value when converting between two euro member currencies. If you omit this argument, the Spreadsheet Component does not round the intermediate euro value. If you include this argument when converting from a euro member currency to the euro, the Spreadsheet Component calculates the intermediate euro value that could then be converted to a euro member currency.

Remarks

  • The Spreadsheet Component truncates any trailing zeros in the return value.

  • If the source ISO code is the same as the target ISO code, the Spreadsheet Component returns the original value of the number.

  • Invalid parameters return #NUM.

  • This function does not apply a number format.

Examples

These examples assume conversion rates of 1 euro = 6.55957 French francs and 1.95583 deutsche marks. The EUROCONVERT function uses the current rates established by the EU. Microsoft will update the function if the rates change. To get full information about the rules and the rates currently in effect, see the European Commission publications about the euro. For information about obtaining these publications and updates to the EUROCONVERT function, connect to the Microsoft Office euro Web site.

The examples show the resulting value stored in the cell, not the formatted value.

EUROCONVERT(1.20,"DEM","EUR") equals 0.61 euro. Because neither full_precision nor triangulation_precision are specified, the result uses the calculation precision for the euro, which is 2 decimal places.

EUROCONVERT(1,"FRF","EUR",TRUE,3) equals 0.152 euro. When converting to euros, if full_precision is TRUE, the result has the precision specified by triangulation_precision.

EUROCONVERT(1,"FRF","EUR",FALSE,3) equals 0.15 euro. When converting to euros, if full_precision is FALSE, the result uses the calculation precision for the euro, which is 2 decimal places.

EUROCONVERT(1,"FRF","DEM",TRUE,3) equals 0.29728616 DM. Because triangulation_precision is 3, the intermediate euro value is rounded to three places. Because full_precision is TRUE, the resulting deutsche mark value is stored with all significant digits.

EUROCONVERT(1,"FRF","DEM",FALSE,3) equals 0.30 DM. Because triangulation_precision is 3, the intermediate euro value is rounded to three places. Because full_precision is FALSE, the resulting deutsche mark value is rounded to the calculation precision for the deutsche mark, which is 2 decimal places.


EVEN

Rounds a number up to the nearest even integer. Negative numbers are adjusted away from 0 (zero).

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

EVEN(number)

Number is the value to round.


EXACT

Compares two text strings and returns TRUE if they are exactly the same, or FALSE if they are not (case-sensitive).

Syntax

EXACT(text1,text2)

Text1 is the first text string.

Text2 is the second text string.


EXP

Returns e raised to the power of a given number.

Syntax

EXP(number)

Number is the exponent applied to the base e. The constant e equals 2.71828182845904, the base of the natural logarithm.


EXPONDIST

Returns the exponential distribution.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

EXPONDIST(x,lambda,cumulative)

X is the value of the function, which is a nonnegative number.

Lambda is the parameter value, a positive number.

Cumulative is a logical value for the function to return: return the cumulative distribution function = TRUE; return the probability density function = FALSE.


FACT

Returns the factorial of a number, which is equal to 1*2*3*...* Number.

Syntax

FACT(number)

Number is the nonnegative number you want the factorial of.


FACTDOUBLE

Returns the double factorial of a number.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

FACTDOUBLE(number)

Number is the nonnegative number you want the double factorial of.


FALSE

Returns the logical value FALSE.

Syntax

FALSE( )


FDIST

Returns the F probability distribution (degree of diversity) for two data sets.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

FDIST(x,degrees_freedom1,degrees_freedom2)

X is the value at which to evaluate the function, which is a nonnegative number.

Deg_freedom1 is the numerator degrees of freedom, a number between 1 and 10^10, excluding 10^10.

Deg_freedom2 is the denominator degrees of freedom, a number between 1 and 10^10, excluding 10^10.


FIND

Finds one text string within another text string and returns the number of the starting position of the string that was found(case-sensitive).

Syntax

FIND(find_text,within_text,start_num)

Find_text is the text you want to find. Use "" (empty text) to match the first character in Within_text; wildcard characters not allowed.

Within_text is the text that contains the text you want to find.

Start_num specifies the character at which to start the search. The first character in Within_text is character number 1. If omitted, Start_num = 1.


FINV

Returns the inverse of the F probability distribution: if p = FDIST(x,...), then FINV(p,....) = x.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

FINV(probability,degrees_freedom1,degrees_freedom2)

Probability is a probability associated with the F cumulative distribution, which is a number between 0 and 1 inclusive.

Deg_freedom1 is the numerator degrees of freedom, a number between 1 and 10^10, excluding 10^10.

Deg_freedom2 is the denominator degrees of freedom, a number between 1 and 10^10, excluding 10^10.


FISHER

Returns the Fisher transformation.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

FISHER(x)

X is the value for which you want the transformation, which is a number between -1 and 1, excluding -1 and 1.


FISHERINV

Returns the inverse of the Fisher transformation: if y = FISHER(x), then FISHERINV(y) = x.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

FISHERINV(y)

Y is the value for which you want to perform the inverse of the transformation.


FIXED

Rounds a number to the specified number of decimals, formats the number in decimal format using a period and commas, and returns the result as text.

Syntax

FIXED(number,decimals,no_commas)

Number is the number you want to round and convert to text.

Decimals is the number of digits to the right of the decimal point.

No_commas is a logical value that, if TRUE, prevents FIXED from including commas in the returned text. If no_commas is FALSE or omitted, then the returned text includes commas as usual.

  • Numbers can never have more than 15 significant digits, but decimals can be as large as 127.

  • If decimals is negative, number is rounded to the left of the decimal point.

  • If you omit decimals, it is assumed to be 2.


FLOOR

Rounds a number down, toward 0 (zero), to the nearest multiple of significance.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

FLOOR(number,significance)

Number is the numeric value you want to round.

Significance is the multiple to which you want to round. Number and Significance must both be positive or both be negative.


FORECAST

Calculates, or predicts, a future value by using existing values. The predicted value is a y-value for a given x-value. The known values are existing x-values and y-values, and the new value is predicted by using linear regression. You can use this function to predict future sales, inventory requirements, or consumer trends.

Syntax

FORECAST(x,known_y's,known_x's)

X is the data point for which you want to predict a value.

Known_y's is the dependent array or range of data.

Known_x's is the independent array or range of data.


FTEST

Returns the result of an F-test, the one-tailed probability that the variances in Array1 and Array2 are not significantly different.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

FTEST(array1,array2)

Array1 is the first range of data and can be numbers or references that contain numbers (blanks are ignored).

Array2 is the second range of data and can be numbers or references that contain numbers (blanks are ignored).


FV

Returns the future value of an investment based on periodic, constant payments and a constant interest rate.

Syntax

FV(rate,nper,pmt,pv,type)

Rate is the interest rate per period.

Nper is the total number of payment periods in an annuity.

Pmt is the payment made each period; it cannot change over the life of the annuity.

Pv is the present value, or the lump-sum amount that a series of future payments is worth now. If omitted, Pv = 0.

Type is a logical value that represents the timing of payment: payment at the beginning of the period = 1; payment at the end of the period = 0 or omitted.


FVSCHEDULE

Returns the future value of an initial principal after applying a series of compound interest rates.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

FVSCHEDULE(principal,schedule)

Principal is the present value of the investment.

Schedule is a range of interest rates to apply in the form of numbers or blank cells; blank cells evaluate as zero (no interest).


GAMMADIST

Returns the gamma distribution.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

GAMMADIST(x,alpha,beta,cumulative)

X is the value at which you want to evaluate the distribution, which is a nonnegative number.

Alpha is a parameter to the distribution, a positive number.

Beta is a parameter to the distribution, a positive number. If Beta = 1, the standard gamma distribution is returned.

Cumulative is a logical value: return the cumulative distribution function = TRUE; return the probability mass function = FALSE or omitted.


GAMMAINV

Returns the inverse of the gamma cumulative distribution: if p = GAMMADIST(x,...), then GAMMAINV(p,...) = x.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

GAMMAINV(probability,alpha,beta)

Probability is the probability associated with the gamma distribution, which is a number between 0 and 1 inclusive.

Alpha is a parameter to the distribution, a positive number.

Beta is a parameter to the distribution, a positive number. If Beta = 1, the inverse of the standard gamma distribution is returned.


GAMMALN

Returns the natural logarithm of the gamma function.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

GAMMALN(x)

X is the value for the gamma function whose logarithm you want, which is a positive number.


GCD

Returns the greatest common divisor of two or more positive integers.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

GCD(number1,number2,...)

Number1 is the first value, which is a positive number.

Number2 Number2, Number3, ... are 1 to 28 values, which are positive numbers.


GEOMEAN

Returns the geometric mean of a range of positive numeric data.

Syntax

GEOMEAN(number1,number2,...)

Number1 Number1, Number2, ... are 1 to 30 numbers or references that contain numbers for which you want the mean.


GESTEP

Returns 1 if Number is greater than or equal to Step; or returns 0 (zero) if it is not.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

GESTEP(number,step)

Number is the value to test against Step.

Step is the threshold value. If omitted, uses 0 (zero).


HARMEAN

Returns the harmonic mean of a data set of positive numbers, which is the reciprocal of the arithmetic mean of reciprocals.

Syntax

HARMEAN(number1,number2,...)

Number1 Number1, Number2, ... are 1 to 30 numbers or references that contain numbers whose harmonic mean you want.


HEX2BIN

Converts a hexadecimal number to a binary number. Negative numbers are returned as 10-character (10-bit) binary numbers in two's-complement notation. The most significant bit (MSB) is the sign bit.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

HEX2BIN(number,places)

Number is the hexadecimal number to convert, up to 10 characters. Negative numbers use two's-complement notation, with the MSB as the sign bit.

Places is the number of characters to use. If omitted, uses the minimum number of characters necessary. Useful to pad with leading zeros.


HEX2DEC

Converts a hexadecimal number to a decimal number.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

HEX2DEC(number)

Number is the hexadecimal number to convert, up to 10 characters. Negative numbers use two's-complement notation, with the most significant bit as the sign bit.


HEX2OCT

Converts a hexadecimal number to an octal number. Negative numbers are returned as 10-character (30-bit) binary numbers in two's-complement notation. The most significant bit (MSB) is the sign bit.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

HEX2OCT(number,places)

Number is the hexadecimal number to convert, up to 10 characters. Negative numbers use two's-complement notation, with the MSB as the sign bit.

Places is the number of characters to use. If omitted, uses the minimum number of characters necessary. Useful to pad with leading zeros.


HLOOKUP

Looks for a value in the top row of a table or range of values, and returns the value in the same column from a row you specify.

Syntax

HLOOKUP(lookup_value,table_array,row_index_num,range_lookup)

Lookup_value is the value to be found in the first row of the table and can be a value, a reference, or a text string.

Table_array is a reference to a table of text, numbers, or logical values in which data is looked up.

Row_index_num is the row number in table_array from which the matching value should be returned. The first row of values in the table is row 1.

Range_lookup is a logical value: to find an exact match = FALSE; to find an approximate match in a table sorted in ascending order = TRUE or omitted.


HOUR

Returns the hour, an integer from 0 (12:00 A.M.) to 23 (11:00 P.M.) that corresponds to a serial number.

Syntax

HOUR(serial_number)

Serial_number is a number that represents the time, or text in time format, such as "16:48:00" or "4:48:00 PM".


HYPERLINK

Creates a shortcut or jump that opens a document stored on your hard drive, a network server, or the Internet.

Syntax

HYPERLINK(link_location,friendly_name)

Link_location is the text that gives the path to and file name of the document to be opened, a hard drive location, a UNC address, or a URL path.

Friendly_name is text or a number that is displayed in the cell. If omitted, the cell displays the Link_location text.


HYPGEOMDIST

Returns the hypergeometric distribution.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

HYPGEOMDIST(sample_s,number_sample,population_s,number_population)

Sample_s is the number of successes in the sample, which is a nonnegative integer.

Number_sample is the size of the sample, a nonnegative integer.

Population_s is the number of successes in the population, a nonnegative integer.

Number_population is the population size, a nonnegative integer.


IF

Returns one value if a condition you specify evaluates to TRUE and another value if it evaluates to FALSE.

Syntax

IF(logical_test,value_if_true,value_if_false)

Logical_test is any value or expression that can be evaluated to TRUE or FALSE. For example, A10 = 100 is a logical expression. If the value in cell A10 is equal to 100, the expression evaluates to TRUE; otherwise, the expression evaluates to FALSE.

Value_if_true is the value that is returned if Logical_test is TRUE. For example, if this argument is the text string "Within budget" and the Logical_test argument evaluates to TRUE, then the IF function displays the text "Within budget". If Logical_test is TRUE and Value_if_true is blank, this argument returns 0 (zero). To display the word TRUE, use the logical value TRUE for this argument. Value_if_true can be another formula.

Value_if_false is the value that is returned if Logical_test is FALSE. For example, if this argument is the text string "Over budget" and the Logical_test argument evaluates to FALSE, then the IF function displays the text "Over budget". If Logical_test is FALSE and Value_if_false is omitted (that is, after Value_if_true, there is no comma), then the logical value FALSE is returned. If Logical_test is FALSE and Value_if_false is blank (that is, after Value_if_true, there is a comma followed by the closing parenthesis), then the value 0 (zero) is returned. Value_if_false can be another formula.

Examples

On a budget sheet, cell A10 contains a formula to calculate the current budget. If the result of the formula in A10 is less than or equal to 100, then the following function displays "Within budget". Otherwise, the function displays "Over budget".

IF(A10<=100,"Within budget","Over budget")

In the following example, if the value in cell A10 is 100, then Logical_test is TRUE, and the total value for the range B5:B15 is calculated. Otherwise, Logical_test is FALSE, and empty text ("") is returned that blanks the cell that contains the IF function.

IF(A10=100,SUM(B5:B15),"")


IMABS

Returns the absolute value (modulus) of a complex number in x + yi or x + yj text format.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

IMABS(inumber)

Inumber is a complex number whose absolute value you want.


IMAGINARY

Returns the imaginary coefficient of a complex number in x + yi or x + yj text format.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

IMAGINARY(inumber)

Inumber is a complex number whose imaginary coefficient you want.


IMARGUMENT

Returns the argument theta, an angle expressed in radians, for a complex number in x + yi or x + yj text format.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

IMARGUMENT(inumber)

Inumber is a complex number whose argument theta you want.


IMCONJUGATE

Returns the complex conjugate of a complex number in x + yi or x + yj text format.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

IMCONJUGATE(inumber)

Inumber is a complex number whose conjugate you want.


IMCOS

Returns the cosine of a complex number in x + yi or x + yj text format.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

IMCOS(inumber)

Inumber is a complex number whose cosine you want.


IMDIV

Returns the quotient of two complex numbers in x + yi or x + yj text format.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

IMDIV(inumber1,inumber2)

Inumber1 is the complex numerator or dividend.

Inumber2 is the complex denominator or divisor.


IMEXP

Returns the exponential of a complex number in x + yi or x + yj text format.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

IMEXP(inumber)

Inumber is a complex number whose exponential you want.


IMLN

Returns the natural logarithm of a complex number in x + yi or x + yj text format.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

IMLN(inumber)

Inumber is a complex number whose natural logarithm you want.


IMLOG10

Returns the common logarithm (base 10) of a complex number in x + yi or x + yj text format.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

IMLOG10(inumber)

Inumber is a complex number whose common logarithm you want.


IMLOG2

Returns the base-2 logarithm of a complex number in x + yi or x + yj text format.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

IMLOG2(inumber)

Inumber is a complex number whose base-2 logarithm you want.


IMPOWER

Returns a complex number in x + yi or x + yj text format raised to an integer power.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

IMPOWER(inumber,number)

Inumber is a complex number that you want to raise to a power.

Number is the power you want to raise the complex number to, which can be an integer, fractional, or negative number.


IMPRODUCT

Returns the product of 2 to 29 complex numbers in x + yi or x + yj text format.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

IMPRODUCT(inumber1,inumber2,...)

Inumber1 is the first complex number to multiply.

Inumber2 Inumber2, Inumber3, ... are 2 to 29 complex numbers to multiply. If omitted, Inumber2 = 1.


IMREAL

Returns the real coefficient of a complex number in x + yi or x + yj text format.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

IMREAL(inumber)

Inumber is a complex number whose real coefficient you want.


IMSIN

Returns the sine of a complex number in x + yi or x + yj text format.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

IMSIN(inumber)

Inumber is a complex number whose real coefficient you want.


IMSQRT

Returns the square root of a complex number in x + yi or x + yj text format.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

IMSQRT(inumber)

Inumber is a complex number whose square root you want.


IMSUB

Returns the difference of two complex numbers in x + yi or x + yj text format.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

IMSUB(inumber1,inumber2)

Inumber1 is the complex number to subtract Inumber2 from.

Inumber2 is the complex number to subtract from Inumber1.


IMSUM

Returns the sum of two or more complex numbers in x + yi or x + yj text format.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

IMSUM(inumber1,inumber2,...)

Inumber1 Inumber1, Inumber2, ... are 1 to 29 complex numbers to add.


INDEX

Returns a value or the reference to a value from within a table or range.

Syntax

INDEX(reference,row_num,column_num,area_num)

Reference is a reference to one or more cell ranges.

Row_num selects the row in reference to return a value from. If omitted, column_num is required.

Column_num selects the column in reference to return a value from. If omitted, row_num is required.

Area_num selects a range in reference to return a value from. The first area selected or entered is area 1, the second area is area 2, and so on.


INDIRECT

Returns the reference specified by a text string.

Syntax

INDIRECT(ref_text,a1)

Ref_text is a reference to a cell that contains an A1-style reference or a reference to a cell as a text string.

A1 is a logical value that specifies the type of reference in ref_text. If you use this argument, the value must be 1 or TRUE. If the argument is omitted, the value is assumed to be 1.


INT

Rounds a number down to the nearest integer.

Syntax

INT(number)

Number is the real number you want to round down to an integer.


INTERCEPT

Calculates the point at which a line will intersect the y-axis by using a best-fit regression line plotted through the known x-values and y-values.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

INTERCEPT(known_y's,known_x's)

Known_y's is the dependent set of observations or data, which can be numbers or references that contain numbers.

Known_x's is the independent set of observations or data, which can be numbers or references that contain numbers.


INTRATE

Returns the interest rate for a fully invested security.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

INTRATE(settlement,maturity,investment,redemption,basis)

Settlement is the security's settlement date: the date after the issue date when the security is traded to the buyer.

Maturity is the security's maturity date: the date when the security expires, expressed as a serial number.

Investment is the amount invested in the security.

Redemption is the amount to be received at maturity.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


IPMT

Returns the interest payment for a given period for an investment, based on periodic, constant payments and a constant interest rate.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

IPMT(rate,per,nper,pv,fv,type)

Rate is the interest rate per period.

Per is the period you want to find the interest for and must be in the range 1 to Nper.

Nper is the total number of payment periods in an annuity.

Pv is the present value, or the lump-sum amount that a series of future payments is worth now.

Fv is the future value, or a cash balance you want to attain after the last payment is made. If omitted, Fv = 0.

Type is a logical value that represents the timing of payment: at the end of the period = 0 or omitted, at the beginning of the period = 1.


IRR

Returns the internal rate of return for a series of cash flows.

Syntax

IRR(values,guess)

Values is a reference to cells that contain numbers whose internal rate of return you want to calculate.

Guess is a number that you guess is close to the result of IRR; 0.1 (10 percent) if omitted.


ISBLANK

Returns TRUE if the value refers to an empty cell.

Syntax

ISBLANK(value)

Value is the cell you want tested.


ISERR

Returns TRUE if the value is any error value except #N/A (value not available). Returns #CIRC! if the value is the #CIRC! error value.

Syntax

ISERR(value)

Value is a reference to a cell or a formula. If value refers to a cell that contains the #CIRC! error value, ISERR displays #CIRC! instead of TRUE.


ISERROR

Returns TRUE if the value is any of the following error values: #N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME?, or #NULL. Returns #CIRC! if the value is the #CIRC! error value.

Syntax

ISERROR(value)

Value is a reference to a cell or a formula.


ISEVEN

Returns TRUE if a number is even, or FALSE if a number is odd.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

ISEVEN(number)

Number is a reference to a cell or a formula.


ISLOGICAL

Returns TRUE if the value is a logical value, which is TRUE or FALSE.

Syntax

ISLOGICAL(value)

Value is a reference to a cell or a formula.


ISNA

Returns TRUE if the value is the #N/A (value not available) error value.

Syntax

ISNA(value)

Value is a reference to a cell or a formula.


ISNONTEXT

Returns TRUE if the value is not text (blank cells are not text).

Syntax

ISNONTEXT(value)

Value is a reference to a cell or a formula.


ISNUMBER

Returns TRUE if the value is a number.

Syntax

ISNUMBER(value)

Value is a reference to a cell or a formula.


ISODD

Returns TRUE if a number is odd, or FALSE if a number is even.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

ISODD(number)

Number is a reference to a cell or a formula.


ISREF

Returns TRUE if the value is a reference.

Syntax

ISREF(value)

Value is a reference to a cell or a formula.


ISTEXT

Returns TRUE if the value is text.

Syntax

ISTEXT(value)

Value is a reference to a cell or a formula.


KURT

Returns the kurtosis of a data set.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

KURT(number1,number2,...)

Number1 Number1, Number2, ... are 1 to 30 numbers or references that contain numbers whose kurtosis you want.


LARGE

Returns the k-th largest value in a data set.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

LARGE(array,k)

Array is the range of data whose k-th largest value you want.

K is the position (from the largest) in the range of the value to return.


LCM

Returns the least common multiple of two or more positive integers.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

LCM(number1,number2,...)

Number1 is the first value, which is a positive number.

Number2 Number2, Number3, ... are 1 to 28 values, positive numbers. If Number2 is omitted, the value is assumed to be 1.


LEFT

Returns the first character or characters in a text string.

Syntax

LEFT(text,num_chars)

Text is the text string that contains the characters you want to extract.

Num_chars specifies how many characters you want to extract; 1 if omitted.


LEN

Returns the number of characters in a text string.

Syntax

LEN(text)

Text is the text whose length you want to find. Spaces count as characters.


LN

Returns the natural logarithm of a number.

Syntax

LN(number)

Number is the positive real number whose natural logarithm you want.


LOG

Returns the logarithm of a number to the base you specify.

Syntax

LOG(number,base)

Number is the positive real number whose logarithm you want.

Base is the base of the logarithm; 10 if omitted.


LOG10

Returns the base-10 logarithm of a number.

Syntax

LOG10(number)

Number is the positive real number whose base-10 logarithm you want.


LOGINV

Returns the inverse of the lognormal cumulative distribution function of x, where ln(x) is normally distributed with parameters Mean and Standard_dev.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

LOGINV(probability,mean,standard_dev)

Probability is a probability associated with the lognormal distribution, which is a number between 0 and 1 inclusive.

Mean is the mean of ln(x).

Standard_dev is the standard deviation of ln(x), a positive number.


LOGNORMDIST

Returns the cumulative lognormal distribution of x, where ln(x) is normally distributed with parameters Mean and Standard_dev.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

LOGNORMDIST(x,mean,standard_dev)

X is the value at which to evaluate the function, which is a positive number.

Mean is the mean of ln(x).

Standard_dev is the standard deviation of ln(x), a positive number.


LOOKUP

Returns a value from either a one-row or one-column range or from a reference.

Syntax

LOOKUP(lookup_value,lookup_vector,result_vector)

Lookup_value is a value that LOOKUP searches for in Lookup_vector, which can be a number, text, logical value, or reference to a value.

Lookup_vector is a range that contains only one row or one column of text, numbers, or logical values, which are placed in ascending order.

Result_vector is a range that contains only one row or column, the same size as Lookup_vector.


LOWER

Converts all uppercase letters in a text string to lowercase letters.

Syntax

LOWER(text)

Text is the text you want to convert to lowercase. Characters in Text that are not letters are not changed.


MATCH

Returns the relative position of an item in a range that matches a specified value in a specified order.

Syntax

MATCH(lookup_value,lookup_array,match_type)

Lookup_value is the value you use to find the value you want in the range, a number, text, or logical value, or a reference to one of these.

Lookup_array is a contiguous range of cells that contain possible lookup values.

Match_type is a number 1 (lookup_array must be sorted in ascending order and the biggest value that is less than or equal to lookup_value is returned), 0 (an exact match to lookup_value is returned, regardless of the order of lookup_array), or -1 (lookup_array must be sorted in descending order and the smallest value that is greater than or equal to lookup_value is returned), indicating which value to return.


MAX

Returns the largest value in a set of values. Ignores logical values and text.

Syntax

MAX(number1,number2,...)

Number1 Number1, Number2, ... are 1 to 30 numbers, empty cells, logical values, or text numbers for which you want the maximum.


MAXA

Returns the largest value in a set of values. Does not ignore logical values and text.

Syntax

MAXA(value1,value2,...)

Value1 Value1, Value2, ... are 1 to 30 numbers, empty cells, logical values, or text numbers for which you want the maximum.


MDURATION

Returns the Macauley modified duration for a security with an assumed par value of $100.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

MDURATION(settlement,maturity,coupon,yld,frequency,basis)

Settlement is the security's settlement date: the date after the issue date when the security is traded to the buyer.

Maturity is the security's maturity date: the date when the security expires.

Coupon is the security's annual coupon rate.

Yld is the security's annual yield.

Frequency is the number of coupon payments per year. Annual payments = 1; semiannual = 2; quarterly = 4.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


MEDIAN

Returns the median of the given numbers.

Syntax

MEDIAN(number1,number2,...)

Number1 Number1, Number2, ... are 1 to 30 numbers or references that contain numbers for which you want the median.


MID

Returns a specific number of characters from a text string starting at the position you specify.

Syntax

MID(text,start_num,num_chars)

Text is the text string from which you want to extract the characters.

Start_num is the position of the first character you want to extract. The first character in Text is 1.

Num_chars specifies how many characters to return from Text.


MIN

Returns the smallest number in a set of values. Ignores logical values and text.

Syntax

MIN(number1,number2,...)

Number1 Number1, Number2, ... are 1 to 30 numbers, empty cells, logical values, or text numbers for which you want the minimum.


MINA

Returns the smallest value in a set of values. Does not ignore logical values and text.

Syntax

MINA(value1,value2, ...)

Value1 Value1, Value2, ... are 1 to 30 numbers, empty cells, logical values, or text numbers for which you want the minimum.


MINUTE

Returns the minute, an integer from 0 to 59, that correspond to a serial number.

Syntax

MINUTE(serial_number)

Serial_number is a number in the date-time code or text in time format, such as "16:48:00" or "4:48:00 PM".


MIRR

Returns the internal rate of return for a series of periodic cash flows, by considering both cost of investment and interest on reinvestment of cash.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

MIRR(values,finance_rate,reinvest_rate)

Values is a reference to cells that contain numbers that represent a series of payments (negative) and income (positive) at regular periods.

Finance_rate is the interest rate you pay on the money used in the cash flows.

Reinvest_rate is the interest rate you receive on the cash flows as you reinvest them.


MOD

Returns the remainder after a number is divided by a divisor.

Syntax

MOD(number,divisor)

Number is the number for which you want to find the remainder after the division is performed.

Divisor is the number by which you want to divide Number.


MODE

Returns the most frequently occurring, or repetitive, value in a range of data.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

MODE(number1,number2,...)

Number1 Number1, Number2, ... are 1 to 30 numbers or references that contain numbers for which you want the mode.


MONTH

Returns the month, an integer from 1 (January) to 12 (December), that corresponds to a serial number.

Syntax

MONTH(serial_number)

Serial_number is a number in date-time code used or text in date format, such as "4-1-1999" or "31-Oct-2000".


MROUND

Returns a number rounded up to the desired multiple.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

MROUND(number,multiple)

Number is the value to round.

Multiple is the multiple to which you want to round Number.


MULTINOMIAL

Returns the ratio of the factorial of a sum of values to the product of factorials.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

MULTINOMIAL(number1,number2,...)

Number1 Number1, Number2, ... are 1 to 29 values for which you want the multinomial.


N

Converts a value to a number. Converts Numbers to numbers, Dates to serial numbers, TRUE to 1, anything else to 0 (zero).

Syntax

N(value)

Value is the value you want to convert.


NA

Returns the error value #N/A (no value available).

Syntax

NA( )


NEGBINOMDIST

Returns the negative binomial distribution, the probability that there will be Number_f failures before the Number_s-th success, with Probability_s probability of a success.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

NEGBINOMDIST(number_f,number_s,probability_s)

Number_f is the number of failures.

Number_s is the threshold number of successes.

Probability_s is the probability of a success; a number between 0 and 1.


NETWORKDAYS

Returns the number of whole working days between a start and end date, excluding weekends and any identified holidays.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

NETWORKDAYS(start_date,end_date,holidays)

Start_date is a date that represents the start date.

End_date is a date that represents the end date.

Holidays is an optional range of one or more days (holidays) to exclude from the working calendar.


NOMINAL

Returns the nominal annual interest rate, given the effective rate and the number of compounding periods per year.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

NOMINAL(effect_rate,npery)

Effect_rate is the effective annual interest rate.

Npery is the number of compounding periods per year.


NORMDIST

Returns the normal cumulative distribution for the specified mean and standard deviation.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

NORMDIST(x,mean,standard_dev,cumulative)

X is the value for which you want the distribution.

Mean is the arithmetic mean of the distribution.

Standard_dev is the standard deviation of the distribution, a positive number.

Cumulative is a logical value: for the cumulative distribution function, use TRUE; for the probability mass function, use FALSE.


NORMINV

Returns the inverse of the normal cumulative distribution for the specified mean and standard deviation.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

NORMINV(probability,mean,standard_dev)

Probability is a probability that corresponds to the normal distribution, a number between 0 and 1 inclusive.

Mean is the arithmetic mean of the distribution.

Standard_dev is the standard deviation of the distribution, a positive number.


NORMSDIST

Returns the standard normal cumulative distribution (has a mean of 0 [zero] and a standard deviation of 1).

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

NORMSDIST(z)

Z is the value for which you want the distribution.


NORMSINV

Returns the inverse of the standard normal cumulative distribution (has a mean of 0 [zero] and a standard deviation of 1).

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

NORMSINV(probability)

Probability is a probability that corresponds to the normal distribution, a number between 0 and 1 inclusive.


NOT

Reverses the logic of its argument: returns FALSE for a TRUE argument and TRUE for a FALSE argument.

Syntax

NOT(logical)

Logical is a value or expression that can be evaluated to TRUE or FALSE.


NOW

Returns the serial number of the current date and time whenever the sheet changes.

Syntax

NOW( )


NPER

Returns the number of periods for an investment based on periodic constant payments and a constant interest rate.

Syntax

NPER(rate,pmt,pv,fv,type)

Rate is the interest rate per period.

Pmt is the payment made each period and cannot change over the life of the annuity.

Pv is the present value, or the lump-sum amount that a series of future payments is worth now.

Fv is the future value, or a cash balance you want to attain after the last payment is made. If omitted, 0 (zero) is used.

Type is a logical value: payment at the beginning of the period = 1; payment at the end of the period = 0 or omitted.


NPV

Returns the net present value of an investment based on a discount rate and a series of future payments (negative values) and income (positive values).

Syntax

NPV(rate,value1,value2, ...)

Rate is the rate of discount over the length of one period.

Value1 Value1, Value2, ... are 1 to 29 payments and income that are equally spaced in time and occur at the end of each period.


OCT2BIN

Converts an octal number to binary. Negative numbers are returned as 10-character (10-bit) binary numbers in two's-complement notation. The most significant bit (MSB) is the sign bit.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

OCT2BIN(number,places)

Number is the octal number to convert, up to 10 characters. Negative numbers use two's-complement notation with the MSB as the sign bit.

Places is the number of characters to use. If omitted, uses the minimum number of characters necessary. Useful to pad with leading zeros.


OCT2DEC

Converts an octal number to a decimal number.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

OCT2DEC(number)

Number is the octal number to convert, up to 10 characters. Negative numbers use two's-complement notation with the most significant bit as the sign bit.


OCT2HEX

Converts an octal number to a hexadecimal number.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

OCT2HEX(number,places)

Number is the octal number to convert, up to 10 characters. Negative numbers use two's-complement notation with the most significant bit as the sign bit.

Places is the number of characters to use. If omitted, uses the minimum number of characters necessary. Useful to pad with leading zeros.


ODD

Rounds a number up to the nearest odd integer.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

ODD(number)

Number is the value to round.


ODDFPRICE

Returns the price per $100 face value of a security that has an odd (short or long) first period.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

ODDFPRICE(settlement,maturity,issue,first_coupon,rate,yld,redemption,frequency,basis)

Settlement is the security's settlement date: the date after the issue date when the security is traded to the buyer.

Maturity is the security's maturity date: the date when the security expires.

Issue is the security's issue date.

First_coupon is the security's first coupon date.

Rate is the security's interest rate.

Yld is the security's annual yield.

Redemption is the security's redemption value per $100 face value.

Frequency is the number of coupon payments per year. Annual payments = 1; semiannual = 2; quarterly = 4.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


ODDFYIELD

Returns the yield of a security that has an odd (short or long) first period.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

ODDFYIELD(settlement,maturity,issue,first_coupon,rate,pr,redemption,frequency,basis)

Settlement is the security's settlement date: the date after the issue date when the security is traded to the buyer.

Maturity is the security's maturity date: the date when the security expires.

Issue is the security's issue date.

First_coupon is the security's first coupon date.

Rate is the security's interest rate.

Pr is the security's price.

Redemption is the security's redemption value per $100 face value.

Frequency is the number of coupon payments per year. Annual payments = 1; semiannual = 2; quarterly = 4.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


ODDLPRICE

Returns the price per $100 face value of a security that has an odd (short or long) last coupon period.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

ODDLPRICE(settlement,maturity,last_interest,rate,yld,redemption,frequency,basis)

Settlement is the security's settlement date: the date after the issue date when the security is traded to the buyer.

Maturity is the security's maturity date: the date when the security expires.

Last_interest is the security's last coupon date.

Rate is the security's interest rate.

Yld is the security's annual yield.

Redemption is the security's redemption value per $100 face value.

Frequency is the number of coupon payments per year. Annual payments = 1; semiannual = 2; quarterly = 4.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


ODDLYIELD

Returns the yield of a security that has an odd (short or long) last period.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

ODDLYIELD(settlement,maturity,last_interest,rate,pr,redemption,frequency,basis)

Settlement is the security's settlement date: the date after the issue date when the security is traded to the buyer.

Maturity is the security's maturity date: the date when the security expires.

Last_interest is the security's last coupon date.

Rate is the security's interest rate.

Pr is the security's price per $100 face value.

Redemption is the security's redemption value per $100 face value.

Frequency is the number of coupon payments per year. Annual payments = 1; semiannual = 2; quarterly = 4.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


OFFSET

Returns a reference to a range that is a specified number of rows and columns from a cell or range of cells.

Syntax

OFFSET(reference,rows,cols,height,width)

Reference is the reference from which you want to base the offset, a reference to a cell or range of adjacent cells.

Rows is the number of rows, up or down, that you want the upper-left cell of the result to refer to.

Cols is the number of columns, to the left or right, that you want the upper-left cell of the result to refer to.

Height is the height, in number of rows, that you want the result to be; the same height as Reference if omitted.

Width is the width, in number of columns, that you want the result to be; the same width as Reference if omitted.


OR

Returns TRUE if any argument is TRUE; returns FALSE if all arguments are FALSE.

Syntax

OR(logical1,logical2, ...)

Logical1 Logical1, Logical2, ... are 1 to 30 conditions you want to test that can be either TRUE or FALSE.


PEARSON

Returns the Pearson product moment correlation coefficient, r.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

PEARSON(array1,array2)

Array1 is a set of independent values.

Array2 is a set of dependent values.


PERCENTILE

Returns the k-th percentile of values in a range.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

PERCENTILE(array,k)

Array is the range of data that defines relative standing, up to 8,191 data points.

K is the percentile value that is between 0 through 1 inclusive.


PERCENTRANK

Returns the rank of a value in a data set as a percentage of the data set.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

PERCENTRANK(array,x,significance)

Array is the range of data with numeric values that defines relative standing.

X is the value for which you want to know the rank.

Significance is an optional value that identifies the number of significant digits for the returned percentage, three digits if omitted (0.xxx%).


PERMUT

Returns the number of permutations for a given number of objects that can be selected from the total objects.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

PERMUT(number,number_chosen)

Number is the total number of objects.

Number_chosen is the number of objects in each permutation.


PI

Returns the value of Pi, 3.14159265358979, accurate to 15 digits.

Syntax

PI( )


PMT

Calculates the payment for a loan based on constant payments and a constant interest rate.

Syntax

PMT(rate,nper,pv,fv,type)

Rate is the interest rate per period for the loan.

Nper is the total number of payments for the loan.

Pv is the present value: the total amount that a series of future payments is worth now.

Fv is the future value, or a cash balance you want to attain after the last payment is made, 0 (zero) if omitted.

Type is a logical value: payment at the beginning of the period = 1; payment at the end of the period = 0 or omitted.


POISSON

Returns the Poisson distribution.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

POISSON(x,mean,cumulative)

X is the number of events.

Mean is the expected numeric value, a positive number.

Cumulative is a logical value: for the cumulative Poisson probability, use TRUE; for the Poisson probability mass function, use FALSE.


POWER

Returns the result of a number raised to a power.

Syntax

POWER(number,power)

Number is the base number, any real number.

Power is the exponent to which the base number is raised.


PPMT

Returns the payment on the principal for a given investment based on periodic constant payments and a constant interest rate.

Syntax

PPMT(rate,per,nper,pv,fv,type)

Rate is the interest rate per period.

Per specifies the period and must be in the range 1 to nper.

Nper is the total number of payment periods in an annuity.

Pv is the present value: the total amount that a series of future payments is worth now.

Fv is the future value, or cash balance you want to attain after the last payment is made.

Type is a logical value: payment at the beginning of the period = 1; payment at the end of the period = 0 or omitted.


PRICE

Returns the price per $100 face value of a security that pays periodic interest.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

PRICE(settlement,maturity,rate,yld,redemption,frequency,basis)

Settlement is the security's settlement date: the date after the issue date when the security is traded to the buyer.

Maturity is the security's maturity date: the date when the security expires.

Rate is the security's annual coupon rate.

Yld is the security's annual yield.

Redemption is the security's redemption value per $100 face value.

Frequency is the number of coupon payments per year. Annual payments = 1; semiannual = 2; quarterly = 4.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


PRICEDISC

Returns the price per $100 face value of a discounted security.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

PRICEDISC(settlement,maturity,discount,redemption,basis)

Settlement is the security's settlement date: the date after the issue date when the security is traded to the buyer.

Maturity is the security's maturity date: the date when the security expires.

Discount is the security's discount rate.

Redemption is the security's redemption value per $100 face value.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


PRICEMAT

Returns the price per $100 face value of a security that pays interest at maturity.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

PRICEMAT(settlement,maturity,issue,rate,yld,basis)

Settlement is the security's settlement date: the date after the issue date when the security is traded to the buyer.

Maturity is the security's maturity date: the date when the security expires.

Issue is the security's issue date.

Rate is the security's interest rate at date of issue.

Yld is the security's annual yield.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


PROB

Returns the probability that values in a range are between two limits or equal to a lower limit.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

PROB(x_range,prob_range,lower_limit,upper_limit)

X_range is the range of numeric values of x with which there are associated probabilities.

Prob_range is the set of probabilities associated with values in X_range, values between 0 and 1 and excluding 0.

Lower_limit is the lower bound on the value for which you want a probability.

Upper_limit is the optional upper bound on the value. If omitted, PROB returns the probability that X_range values are equal to Lower_limit.


PRODUCT

Multiplies all the numbers given as arguments and returns the product.

Syntax

PRODUCT(number1,number2,...)

Number1 Number1, number2, ... are 1 to 30 numbers, logical values, or text representations of numbers that you want to multiply.


PROPER

Capitalizes the first letter in each word of a text string and converts all other letters to lowercase letters.

Syntax

PROPER(text)

Text is text enclosed in quotation marks, a formula that returns text, or a reference to a cell that contains text to partially capitalize.


PV

Returns the present value of an investment: the total amount that a series of future payments is worth now.

Syntax

PV(rate,nper,pmt,fv,type)

Rate is the interest rate per period.

Nper is the total number of payment periods in an annuity.

Pmt is the payment made each period and cannot change over the life of the annuity.

Fv is the future value, or a cash balance you want to attain after the last payment is made.

Type is a logical value: payment at the beginning of the period = 1; payment at the end of the period = 0 or omitted.


QUARTILE

Returns the quartile of a data set.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

QUARTILE(array,quart)

Array is the cell range of numeric values for which you want the quartile value.

Quart is a number: minimum value = 0; 1st quartile = 1; median value = 2; 3rd quartile = 3; maximum value = 4.


QUOTIENT

Returns the integer portion of a division and discards the remainder.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

QUOTIENT(numerator,denominator)

Numerator is the dividend.

Denominator is the divisor.


RADIANS

Converts degrees to radians.

Syntax

RADIANS(angle)

Angle is an angle in degrees that you want to convert.


RAND

Returns an evenly distributed random number greater than or equal to 0 (zero) and less than 1 (changes whenever the sheet changes).

Syntax

RAND( )


RANDBETWEEN

Returns a random number between the numbers you specify (changes whenever the sheet changes).

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

RANDBETWEEN(bottom,top)

Bottom is the smallest integer you want to return.

Top is the largest integer you want to return.


RANK

Returns the rank of a number in a list of numbers, with its size relative to other values in the list.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

RANK(number,ref,order)

Number is the number whose rank you want to find.

Ref is a range or reference to a list of numbers. Nonnumeric values are ignored.

Order is a number: rank in the list sorted descending = 0 or omitted; rank in the list sorted ascending = any nonzero value.


RATE

Returns the interest rate per period of an annuity.

Syntax

RATE(nper,pmt,pv,fv,type,guess)

Nper is the total number of payment periods in an annuity.

Pmt is the payment made each period and cannot change over the life of the annuity.

Pv is the present value: the total amount that a series of future payments is worth now.

Fv is the future value, or a cash balance you want to attain after the last payment is made. If omitted, uses Fv = 0.

Type is a logical value: payment at the beginning of the period = 1; payment at the end of the period = 0 or omitted.

Guess is your guess for what the rate will be.

  • If you omit guess, it is assumed to be 10 percent.

  • If RATE does not converge, try different values for guess. RATE usually converges if guess is between 0 and 1.


RECEIVED

Returns the amount received at maturity for a fully invested security.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

RECEIVED(settlement,maturity,investment,discount,basis)

Settlement is the security's settlement date: the date after the issue date when the security is traded to the buyer.

Maturity is the security's maturity date: the date when the security expires.

Investment is the amount invested in the security.

Discount is the security's discount rate.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


REPLACE

Replaces part of a text string with a different text string.

Syntax

REPLACE(old_text,start_num,num_chars,new_text)

Old_text is text in which you want to replace some characters.

Start_num is the position of the character in Old_text that you want to replace with New_text.

Num_chars is the number of characters in Old_text that you want to replace.

New_text is the text that will replace characters in Old_text.


REPT

Repeats text a given number of times. Use REPT to fill a cell with a number of instances of a text string.

Syntax

REPT(text,number_times)

Text is the text you want to repeat.

Number_times is a positive number that specifies the number of times to repeat text.


RIGHT

Returns the last character or characters in a text string.

Syntax

RIGHT(text,num_chars)

Text is the text string that contains the characters you want to extract.

Num_chars specifies how many characters you want to extract, 1 if omitted.


ROMAN

Converts an arabic numeral to a roman numeral, as text.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

ROMAN(number,form)

Number is the arabic numeral you want to convert.

Form is the number that specifies the type of roman numeral you want.


ROUND

Rounds a number to a specified number of digits.

Syntax

ROUND(number,num_digits)

Number is the number you want to round.

Num_digits is the number of digits you want to round to. Negative rounds to the left of the decimal point; 0 (zero) rounds to the nearest integer.


ROUNDDOWN

Rounds a number down, toward 0 (zero).

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

ROUNDDOWN(number,num_digits)

Number is any real number that you want rounded down.

Num_digits is the number of digits you want to round to. Negative rounds to the left of the decimal point; 0 (zero) or omitted rounds to the nearest integer.


ROUNDUP

Rounds a number up, away from 0 (zero).

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

ROUNDUP(number,num_digits)

Number is any real number that you want rounded up.

Num_digits is the number of digits you want to round to. Negative rounds to the left of the decimal point; 0 (zero) or omitted rounds to the nearest integer.


ROW

Returns the row number of a reference.

Syntax

ROW(reference)

Reference is the cell or a single range of cells whose row number you want; if omitted, returns the cell that contains the ROW function.


ROWS

Returns the number of rows in a reference.

Syntax

ROWS(array)

Array is a reference to a range of cells whose number of rows you want.


RSQ

Returns the square of the Pearson product moment correlation coefficient through the given data points.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

RSQ(known_y's,known_x's)

Known_y's is a range of data points and can be numbers or references that contain numbers.

Known_x's is a range of data points and can be numbers or references that contain numbers.


SEARCH

Returns the number of the character at which a specific character or text string is first found, beginning with start_num. Use SEARCH to determine the location of a character or text string within another text string so that you can use the MID or REPLACE functions to change the text.

Syntax

SEARCH(find_text,within_text,start_num)

Find_text is the text you want to find. You can use the wildcard characters, question mark (?) and asterisk (*), in find_text. A question mark matches any single character; an asterisk matches any sequence of characters. If you want to find an actual question mark or asterisk, type a tilde (~) before the character. If find_text is not found, the #VALUE! error value is returned.

Within_text is the text in which you want to search for find_text.

Start_num is the character number in within_text at which you want to start searching.

  • 2If start_num is omitted, it is assumed to be 1.

  • If start_num is not greater than 0 (zero) or is greater than the length of within_text, the #VALUE! error value is returned.


SECOND

Returns the second, an integer in the range 0 to 59, that corresponds to a serial number.

Syntax

SECOND(serial_number)

Serial_number is a number that represents the time or text in time format, such as "16:48:23" or "4:48:47 PM".


SERIESSUM

Returns the sum of a power series.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

SERIESSUM(x,n,m,coefficients)

X is the input value to the power series.

N is the initial power to which you want to raise X.

M is the step by which to increase N for each term in the series.

Coefficients is a set of coefficients by which each successive power of X is multiplied.


SIGN

Returns the sign of a number: 1 if the number is positive, 0 if the number is zero, or -1 if the number is negative.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

SIGN(number)

Number is any real number.


SIN

Returns the sine of an angle.

Syntax

SIN(number)

Number is the angle in radians whose sine you want. Degrees * PI()/180 = radians.


SINH

Returns the hyperbolic sine of a number.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

SINH(number)

Number is any real number.


SKEW

Returns the skewness of a distribution: a characterization of the degree of asymmetry of a distribution around its mean.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

SKEW(number1,number2,...)

Number1 Number1, Number2, ... are 1 to 30 numbers or references that contain numbers for which you want the skewness.


SLN

Returns the straight-line depreciation of an asset for one period.

Syntax

SLN(cost,salvage,life)

Cost is the initial cost of the asset.

Salvage is the salvage value at the end of the life of the asset.

Life is the number of periods over which the asset is being depreciated (sometimes called the useful life of the asset).


SLOPE

Returns the slope of the linear regression line through the given data points.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

SLOPE(known_y's,known_x's)

Known_y's is a cell range of numeric dependent data points and can be numbers or references that contain numbers.

Known_x's is the set of independent data points and can be numbers or references that contain numbers.


SMALL

Returns the k-th smallest value in a data set.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

SMALL(array,k)

Array is a range of numerical data for which you want to determine the k-th smallest value.

K is the position (from the smallest) in the range of the value to return.


SQRT

Returns a square root of a number.

Syntax

SQRT(number)

Number is the number whose square root you want.


SQRTPI

Returns the square root of a number multiplied by Pi.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

SQRTPI(number)

Number is the number by which Pi is multiplied.


STANDARDIZE

Returns a normalized value from a distribution characterized by a mean and standard deviation.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

STANDARDIZE(x,mean,standard_dev)

X is the value you want to normalize.

Mean is the arithmetic mean of the distribution.

Standard_dev is the standard deviation of the distribution, a positive number.


STDEV

Estimates standard deviation based on a sample (ignores logical values and text in the sample).

Syntax

STDEV(number1,number2,...)

Number1 Number1, Number2, ... are 1 to 30 numbers that correspond to a sample of a population and can be numbers or references that contain numbers.


STDEVA

Estimates standard deviation based on a sample, including logical values and text. Text and the logical value FALSE have the value 0 (zero); the logical value TRUE has the value 1.

Syntax

STDEVA(value1,value2,...)

Value1 Value1, Value2, ... are 1 to 30 values that correspond to a sample of a population and can be values or references to values.


STDEVP

Calculates standard deviation based on the entire population given as arguments (ignores logical values and text).

Syntax

STDEVP(number1,number2,...)

Number1 Number1, Number2, ... are 1 to 30 numbers that correspond to a population and can be numbers or references that contain numbers.


STDEVPA

Calculates standard deviation based on an entire population, including logical values and text. Text and the logical value FALSE have the value 0 (zero); the logical value TRUE has the value 1.

Syntax

STDEVPA(value1,value2,...)

Value1 Value1, Value2, ... are 1 to 30 values that correspond to a population and can be values or references that contain values.


STEYX

Returns the standard error of the predicted y-value for each x in a regression.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

STEYX(known_y's,known_x's)

Known_y's is a range of dependent data points and can be numbers or references that contain numbers.

Known_x's is a range of independent data points and can be numbers or references that contain numbers.


SUBSTITUTE

Replaces existing text with new text in a text string.

Syntax

SUBSTITUTE(text,old_text,new_text,instance_num)

Text is the text or the reference to a cell that contains the text you want to replace.

Old_text is the existing text you want to replace. If the case of Old_text does not match the case of text, SUBSTITUTE will not replace the text.

New_text is the text you want to replace Old_text with.

Instance_num specifies which occurrence of Old_text you want to replace. If omitted, every instance of Old_text is replaced.


SUBTOTAL

Returns a subtotal in a list or database.

Syntax

SUBTOTAL(function_num,ref1,ref2,...)

Function_num is the number 1 to 11 that specifies the summary function for the subtotal.

Ref1 Ref1, Ref2, ... are 1 to 29 ranges or references whose subtotal you want.


SUM

Adds all the numbers in a range of cells.

Syntax

SUM(number1,number2,...)

Number1 Number1, Number2, ... are 1 to 30 numbers to sum. Logical values and text are ignored in cells; they are included if typed as arguments.


SUMIF

Adds the cells specified by a given condition or criteria.

Syntax

SUMIF(range,criteria,sum_range)

Range is the range of cells you want evaluated.

Criteria is the condition or criteria in the form of a number, expression, or text that defines which cells will be added.

Sum_range specifies the actual cells to sum. If omitted, the cells in the range are used.


SUMPRODUCT

Multiplies corresponding numeric components in given ranges and returns the sum of those products.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

SUMPRODUCT(array1,array2,array3,...)

Array1 is the first range you want to multiply and then add. All ranges must have the same dimensions.

Array2 Array2, Array3, ... are 1 to 29 more ranges whose components you want to multiply and then add.


SUMSQ

Returns the sum of the squares of the arguments. The arguments can be numbers or references to cells that contain numbers.

Syntax

SUMSQ(number1,number2,...)

Number1 Number1, Number2, ... are 1 to 30 numbers or references to cells whose sum of the squares you want.


SUMX2MY2

Calculates the difference between the squares of corresponding numbers in two ranges and then returns the sum of the differences.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

SUMX2MY2(array_x,array_y)

Array_x is the first range of numbers and can be a number or reference that contains numbers.

Array_y is the second range of numbers and can be a number or reference that contains numbers.


SUMX2PY2

Calculates the sum of the squares of corresponding numbers in two ranges and then returns the sum total of the sums.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

SUMX2PY2(array_x,array_y)

Array_x is the first range of numbers and can be a number or reference that contains numbers.

Array_y is the second range of numbers and can be a number or reference that contains numbers.


SUMXMY2

Calculates the differences of corresponding values in two ranges and then returns the sum of the squares of the differences.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

SUMXMY2(array_x,array_y)

Array_x is the first range of values and can be a number or reference that contains numbers.

Array_y is the second range of values and can be a number or reference that contains numbers.


SYD

Returns the sum-of-years' digits depreciation of an asset for a specified period.

Syntax

SYD(cost,salvage,life,per)

Cost is the initial cost of the asset.

Salvage is the salvage value at the end of the life of the asset.

Life is the number of periods over which the asset is being depreciated (sometimes called the useful life of the asset).

Per is the period and must use the same units as Life.


T

Returns the text referred to by Value.

Syntax

T(value)

Value is the value to test: if Value is or refers to text, T returns Value; if Value is not text, T returns "" (empty text).


TAN

Returns the tangent of an angle.

Syntax

TAN(number)

Number is the angle in radians whose tangent you want. Degrees * PI()/180 = radians.


TANH

Returns the hyperbolic tangent of a number.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

TANH(number)

Number is any real number.


TBILLEQ

Returns the bond-equivalent yield for a treasury bill.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

TBILLEQ(settlement,maturity,discount)

Settlement is the treasury bill's settlement date: the date after the issue date when the treasury bill is traded to the buyer.

Maturity is the treasury bill's maturity date: the date when the treasury bill expires.

Discount is the treasury bill's discount rate.


TBILLPRICE

Returns the price per $100 face value for a treasury bill.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

TBILLPRICE(settlement,maturity,discount)

Settlement is the treasury bill's settlement date: the date after the issue date when the treasury bill is traded to the buyer.

Maturity is the treasury bill's maturity date: the date when the treasury bill expires.

Discount is the treasury bill's discount rate.


TBILLYIELD

Returns the yield for a treasury bill.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

TBILLYIELD(settlement,maturity,pr)

Settlement is the treasury bill's settlement date: the date after the issue date when the treasury bill is traded to the buyer.

Maturity is the treasury bill's maturity date: the date when the treasury bill expires.

Pr is the treasury bill's price per $100 face value.


TDIST

Returns the percentage points (probability) for the Student's t-distribution, where a numeric value (x) is a calculated value whose percentage points are to be computed.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

TDIST(x,degrees_freedom,tails)

X is the numeric value at which to evaluate the distribution.

Degrees_freedom is an integer that indicates the number of degrees of freedom that characterize the distribution.

Tails specifies the number of distribution tails to return: one-tailed distribution = 1; two-tailed distribution = 2.


TEXT

Converts a value to text in a specific number format.

Syntax

TEXT(value,format_text)

Value is a number, a formula that evaluates to a numeric value, or a reference to a cell containing a numeric value.

Format_text is a number format (other than the General format) in text form.


TIME

Returns the number that represents a particular time: a decimal fraction from 0 to 0.99999999 for 0:00:00 (12:00:00 A.M.) to 23:59:59 (11:59:59 P.M.).

Syntax

TIME(hour,minute,second)

Hour is a number from 0 to 23 that represents the hour.

Minute is a number from 0 to 59 that represents the minute.

Second is a number from 0 to 59 that represents the second.


TIMEVALUE

Returns the number that represents the time represented by a text string.

Syntax

TIMEVALUE(time_text)

Time_text is a text string that gives a time in any one of the time formats (date information in the string is ignored), such as "18:45".


TINV

Returns the inverse of the Student's t-distribution.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

TINV(probability,deg_freedom)

Probability is the probability associated with the two-tailed Student's t-distribution, a number between 0 and 1 inclusive.

Deg_freedom is a positive integer that indicates the number of degrees of freedom to characterize the distribution.


TODAY

Returns a number that represents today's date. When TODAY is entered in a cell, it is automatically formatted as a date. TODAY changes whenever the sheet changes.

Syntax

TODAY( )


TRIM

Removes all spaces from a text string except for single spaces between words.

Syntax

TRIM(text)

Text is the text you want spaces removed from.


TRIMMEAN

Returns the mean of the interior portion of a set of data values.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

TRIMMEAN(array,percent)

Array is the range of values to trim and average.

Percent is the fractional number of data points to exclude from the beginning and end of the data set.


TRUE

Returns the logical value TRUE.

Syntax

TRUE( )


TRUNC

Truncates a number to an integer by removing the decimal, or fractional, part of the number.

Syntax

TRUNC(number,num_digits)

Number is the number you want to truncate.

Num_digits is a number that specifies the precision of the truncation, 0 (zero) if omitted.


TTEST

Returns the probability associated with a Student's t-test.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

TTEST(array1,array2,tails,type)

Array1 is the first data set.

Array2 is the second data set.

Tails specifies the number of distribution tails to return: one-tailed distribution = 1; two-tailed distribution = 2.

Type is the kind of t-test: paired = 1, two-sample equal variance (homoscedastic) = 2, two-sample unequal variance = 3.


TYPE

Returns the type of value. Use TYPE when the behavior of another function depends on the type of value in a particular cell.

Syntax

TYPE(value)

Value can be any value, such as a number, text, logical value, and so on.

If value is | TYPE returns
Number | 1
Text | 2
Logical value | 4
Error value | 16
Array | 64


UPPER

Converts a text string to uppercase.

Syntax

UPPER(text)

Text is the text you want to convert to uppercase, a reference or a text string.


VALUE

Converts a text string that represents a number to a number.

Syntax

VALUE(text)

Text is the text enclosed in quotation marks or a reference to a cell that contains the text you want to convert.


VAR

Estimates variance based on a sample (ignores logical values and text in the sample).

Syntax

VAR(number1,number2,...)

Number1 Number1, Number2, ... are 1 to 30 numeric arguments that correspond to a sample of a population.


VARA

Estimates variance based on a sample, including logical values and text. Text and the logical value FALSE have the value 0 (zero); the logical value TRUE has the value 1.

Syntax

VARA(value1,value2,...)

Value1 Value1, Value2, ... are 1 to 30 value arguments that correspond to a sample of a population.


VARP

Calculates variance based on the entire population (ignores logical values and text in the population).

Syntax

VARP(number1,number2,...)

Number1 Number1, Number2, ... are 1 to 30 numeric arguments that correspond to a population.


VARPA

Calculates variance based on the entire population, including logical values and text. Text and the logical value FALSE have the value 0 (zero); the logical value TRUE has the value 1.

Syntax

VARPA(value1,value2,...)

Value1 Value1, Value2, ... are 1 to 30 value arguments that correspond to a population.


VDB

Returns the depreciation of an asset for any period you specify, including partial periods, using the double-declining balance method or some other method you specify. VDB stands for variable declining balance.

Syntax

VDB(cost,salvage,life,start_period,end_period,factor,no_switch)

Cost is the initial cost of the asset.

Salvage is the value at the end of the depreciation (sometimes called the salvage value of the asset).

Life is the number of periods over which the asset is being depreciated (sometimes called the useful life of the asset).

Start_period is the starting period for which you want to calculate the depreciation. Start_period must use the same units as life.

End_period is the ending period for which you want to calculate the depreciation. End_period must use the same units as life.

Factor is the rate at which the balance declines. If factor is omitted, it is assumed to be 2 (the double-declining balance method). Change factor if you do not want to use the double-declining balance method. For a description of the double-declining balance method, see DDB.

No_switch is a logical value specifying whether to switch to straight-line depreciation when depreciation is greater than the declining balance calculation.

  • If no_switch is TRUE, VDB does not switch to straight-line depreciation even when the depreciation is greater than the declining balance calculation.

  • If no_switch is FALSE or omitted, VDB switches to straight-line depreciation when depreciation is greater than the declining balance calculation.

Note All arguments except no_switch must be positive numbers.


VLOOKUP

Searches for a value in the first column of a table, and then returns a value in the same row from a column you specify. By default, the table must be sorted in an ascending order.

Syntax

VLOOKUP(lookup_value,table_array,col_index_num,range_lookup)

Lookup_value is the value in the first column of the table, and can be a value, a reference, or a text string.

Table_array is a reference to a table of text, numbers, or logical values from which data is retrieved.

Col_index_num is the column number in table_array from which the matching value should be returned. The first column of values in the table is column 1.

Range_lookup is a logical value: if FALSE, the function finds an exact match; if TRUE or omitted, the table must be sorted in an ascending order and the function finds the largest value that is less than or equal to lookup_value.


WEEKDAY

Returns a number from 1 to 7 that identifies the day of the week, based on a given number that represents a date.

Syntax

WEEKDAY(serial_number,return_type)

Serial_number is a number that represents a date or text in date format, such as "4-1-1999" or "31-Oct-2000".

Return_type is a number: for Sunday = 1 through Saturday = 7, use 1; for Monday = 1 through Sunday = 7, use 2; for Monday = 0 through Sunday = 1, use 3.


WEEKNUM

Returns a number that indicates where the week falls numerically within a year.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

WEEKNUM(serial_num,return_type)

Serial_num is a date within the week as a number that represents the date or text in date format, such as "4-1-1999" or "31-Oct-2000".

Return_type is a number: if the week begins on Sunday, use 1 or omit; if the week begins on Monday, use 2.


WEIBULL

Returns the Weibull distribution.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

WEIBULL(x,alpha,beta,cumulative)

X is the value at which to evaluate the function, a nonnegative number.

Alpha is a parameter to the distribution, a positive number.

Beta is a parameter to the distribution, a positive number.

Cumulative is a logical value: for the cumulative distribution function, use TRUE; for the probability mass function, use FALSE.


WORKDAY

Returns a number that represents a date that is the indicated number of working days before or after start_date, excluding weekends and specified holidays.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

WORKDAY(start_date,days,holidays)

Start_date is a date that represents the start date.

Days is the number of nonweekend and nonholiday days before or after Start_date (negative values for days before).

Holidays is a range of cells that represent dates to exclude from the working calendar.


XIRR

Returns the internal rate of return for a schedule of cash flows that are not periodic. For cash flows that are periodic, use the IRR function.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

XIRR(values,dates,guess)

Values is a series of cash flows that corresponds to a schedule of payment dates in Dates (payments are discounted based on a 365-day year).

Dates is a schedule of payment dates that corresponds to the cash flow payments.

Guess is a number that you guess is close to the result of XIRR, or 0.1 if omitted.


XNPV

Returns the net present value for a schedule of cash flows that is not necessarily periodic. For cash flows that are periodic, use the NPV function.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

XNPV(rate,values,dates)

Rate is the discount rate to apply to the cash flows.

Values is a series of cash flows that corresponds to a schedule of payment dates in Dates (payments are discounted based on a 365-day year).

Dates is a schedule of payment dates that corresponds to the cash flow payments.


YEAR

Returns the year, an integer in the range 1900-9999, that corresponds to a number that represents a date.

Syntax

YEAR(serial_number)

Serial_number is a number that represents the date or text in date format, such as "4-1-1999" or "31-Oct-2000".


YEARFRAC

Calculates the fraction of the year represented by the number of whole days between two dates.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

YEARFRAC(start_date,end_date,basis)

Start_date is a date that represents the first (or start) date.

End_date is a date that represents the last (or end) date.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


YIELD

Returns the yield on a security that pays period interest (bond yield).

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

YIELD(settlement,maturity,rate,pr,redemption,frequency,basis)

Settlement is the security's settlement date: the date after the issue date when the security is traded to the buyer.

Maturity is the security's maturity date: the date when the security expires.

Rate is the security's annual coupon rate.

Pr is the security's price per $100 face value.

Redemption is the security's redemption value per $100 face value.

Frequency is the number of coupon payments per year. Annual payments = 1; semiannual = 2; quarterly = 4.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


YIELDDISC

Returns the annual yield for a discounted security.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

YIELDDISC(settlement,maturity,pr,redemption,basis)

Settlement is the security's settlement date: the date after the issue date when the security is traded to the buyer.

Maturity is the security's maturity date: the date when the security expires.

Pr is the security's price per $100 face value.

Redemption is the security's redemption value per $100 face value.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


YIELDMAT

Returns the annual yield of a security that pays interest at maturity.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

YIELDMAT(settlement,maturity,issue,rate,pr,basis)

Settlement is the security's settlement date: the date after the issue date when the security is traded to the buyer.

Maturity is the security's maturity date: the date when the security expires.

Issue is the security's issue date.

Rate is the security's interest rate at date of issue.

Pr is the security's price per $100 face value.

Basis is a number from 0 through 4 that specifies the type of day count basis to use.


ZTEST

Returns the two-tailed P-value of a z-test.

If this function returns the #NAME? error value, you may need to install msowcf.dll.

Syntax

ZTEST(array,x,sigma)

Array is the range of data against which to test X.

X is the value to test.

Sigma is the population (known) standard deviation. If omitted, the sample standard deviation is used.