action query <Jet definition>

action query

A query that copies or changes data. Action queries include append, delete, make-table, and update queries. Delete and update queries change existing data; append and make-table queries copy existing data. In SQL, these are referred to as DML queries and consist of the keywords DELETE, INSERT, and UPDATE. Microsoft® Jet supports the keyword SELECT INTO, which is also considered a DDL query. In contrast, select queries return data records. An SQL pass-through query may also be an action query.


Active Data Objects <Jet definition>

Active Data Objects (ADO)

A programming interface to access and manipulate database objects.


aggregate function <Jet definition>

aggregate function

A function, such as Sum, Count, Avg, and Max, that you can use to calculate totals. In writing expressions and in programming, you can use SQL aggregate functions (including the four listed here) and domain aggregate functions to determine various statistics.


alias <Jet definition>

alias

Visual Basic: An alternate name you give to an external procedure to avoid conflict with a Microsoft® Visual Basic® keyword, public variable, constant, or a name not allowed by the Visual Basic naming conventions.

Structured Query Language (SQL): An alternate name you give to a field or expression in a SELECT statement, using the optional AS clause. ANSI refers to this as a correlation name.


ANSI Character Set <Jet definition>

ANSI Character Set

An 8-bit character set used by Microsoft® Windows® that allows you to represent up to 256 characters (0 through 255) using your keyboard. The ASCII character set is a subset of the ANSI set.


ANSI SQL 92 mode <Jet definition>

ANSI SQL-92 mode

This mode allows for an increased SQL syntax that is more compliant with SQL-92 and Microsoft® SQL Server™. This mode is only available when going through the Microsoft OLE DB Provider for Jet. It cannot be set when going through DAO. New features are primarily in DDL. Support for the ANSI wildcards, which are the percent sign (%) and the underscore character (_), are also part of the ANSI SQL-92 mode.


append query <Jet definition>

append query

An action query that adds new records to the end of an existing table or query. Append queries do not return records (rows). SQL syntax would contain the INSERT keyword.


argument <Jet definition>

argument

A constant, variable, or expression that supplies additional information to an action, procedure, or method. You use an argument with an operand in an expression to supply additional information required by some action.


array <Jet definition>

array

A variable that contains a finite number of elements that have a common name and data type. Each element of an array is identified by a unique index number. Changes made to one element of an array do not affect the other elements.


ASCII Character Set <Jet definition>

ASCII Character Set

American Standard Code for Information Interchange (ASCII) 7-bit character set widely used to represent letters and symbols found on a standard U.S. keyboard. The ASCII character set is the same as the first 128 characters (0 — 127) in the ANSI character set.


asterisk <Jet definition>

asterisk

A character (*) used as a wildcard in SQL LIKE expressions to accept any string of characters. For example, the expression LIKE "*town*" returns records containing the string "town" followed by zero or more characters.

When you create a query or enter an SQL statement, use the asterisk to include all the fields that currently exist in the underlying table or query. For example, SELECT * FROM MyTable returns all fields (columns) from the table.

When issuing a query through the Microsoft® OLE DB Provider for Jet, the asterisk is no longer used as a wildcard symbol. Instead, the percent sign (%) is used as the ANSI wildcard symbol. Stored queries will not be affected, but new queries (views) that are created through the Microsoft OLE DB Provider for Jet will need to use the ANSI wildcards, the percent sign (%) and the underscore character (_), to get the behavior similar to that provided by the asterisk (*) and the question mark (?). Microsoft OLE DB Provider for Jetwill translate the asterisk and the question mark as literal characters, and the returning result set will be different from going through the Microsoft Access UI or DAO.


asynchronous query <Jet definition>

asynchronous query

A type of query in which SQL queries return immediately, even though the results are still pending. This enables an application to continue with other processing while the query is pending completion.


autonumber field <Jet definition>

AutoNumber field

A field data type that automatically stores a unique number for each record as it is added to a table. An AutoNumber field always uses the Long data type. Numbers generated by an AutoNumber field cannot be modified unless special permission has been granted to the table through either the Grant or Revoke statements in SQL DDL syntax. The AutoNumber field is also known as a Counter or Identity data type. When using SQL DDL, this data type now supports varying seed and increment values. This differs from previous versions where the seed value was 1 and the increment value was 1.

See Also

Identity attribute

seed

increment


base table <Jet definition>

base table

A table in a Microsoft® Jet database. A table defines the structure of a relational database, and is an object that stores data in records and fields. You can manipulate the structure of a base table by using the DAO objects or data definition (DDL) SQL statements, and you can modify data in a base table by using Recordset objects or action queries.


Big Integer data type <Jet definition>

Big Integer data type

A data type that stores a signed, exact numeric value with precision 19 (signed) or 20 (unsigned), scale 0 (signed: -263 ≤ n ≤ 263-1; unsigned: 0 ≤ n ≤ 264-1).


Binary data type <Jet definition>

Binary data type

A data type that stores fixed-length binary data. The maximum length is 255 bytes.


bookmark <Jet definition>

bookmark

A property of the Recordset object that contains a binary string identifying the current record. If you assign the Bookmark value to a variable and then move to another record, you can make the earlier record current again by setting the Bookmark property to that string variable.


Boolean expression <Jet definition>

Boolean expression

An expression that evaluates to either True or False.


Boolean data type <Jet definition>

Boolean data type

A True/False or yes/no value. Boolean values are usually stored in Bit fields in a Microsoft® Jet database; however, some databases do not support this data type directly.


Byte data type <Jet definition>

Byte data type

A fundamental data type used to hold small positive integer numbers ranging from 0 to 255.


Cartesian product <Jet definition>

Cartesian product

The result of joining two relational tables, producing all possible ordered combinations of rows from the first table with all rows from the second table.

Generally, a Cartesian product results from executing an SQL SELECT statement referencing two or more tables in the FROM clause and not including a WHERE or JOIN clause that indicates how the tables are to be joined.


cascade <Jet definition>

cascade

The process of one action triggering another action. For example, when a cascading update relationship is defined for two (or more) tables, an update to the primary key in the primary table automatically triggers (cascades) changes to the foreign table.

Now also definable from SQL DDL.


cascading delete <Jet definition>

cascading delete

For relationships that enforce referential integrity between tables, cascading delete is an option that causes the deletion of a record from the primary table to automatically delete all related records in the related foreign table or tables.

For example, if you establish a relationship between a Customers (primary) table and an Orders (foreign) table with the cascading delete option enabled, when a record in the Customers table is deleted, all orders associated with that customer would also be deleted in the foreign Orders table.

Now also definable from SQL DDL.


cascading update <Jet definition>

cascading update

For relationships enforcing referential integrity between tables, cascading update is an option that causes a change to the primary key in a record in the primary table to automatically update the foreign key in all related records in the related foreign table or tables.

For example, if you establish a relationship between a Customers (primary) table and an Orders (foreign) table with the cascading update option enabled, when the primary key in a record in the Customers table is changed, all orders associated with that customer would also be changed in the foreign Orders table.

Now also definable from SQL DDL.


cascading NULL <Jet definition>

cascading NULL

For relationships enforcing referential integrity between tables, cascading NULL is an option that causes a deleted row in the primary table to automatically update the foreign key in all related records in the related foreign table or tables with a NULL value.

Now also definable from SQL DDL.

For example, if you establish a relationship between a Customers (primary) table and an Orders (foreign) table with the cascading NULL option enabled, when the primary key in a record in the Customers table is deleted, all orders in the foreign Orders table associated with that customer would also be changed to have a NULL value.


case-sensitive <Jet definition>

case-sensitive

Capable of distinguishing between uppercase and lowercase letters. A case-sensitive search finds only text that is an exact match of uppercase and lowercase letters. Such a search would, for instance, treat “ZeroLengthStr” and “zerolengthstr” as different. Microsoft® Jet database operations are not case-sensitive. However, case sensitivity is a feature of some other database management systems.


Char data type <Jet definition>

Char data type

A data type that stores a fixed-length character string. The length is set by the Size property.


CHECK Constraint <Jet definition>

CHECK constraint

An ANSI SQL-92 concept that allows for business rules that span an entire table or multiple other tables to be created. An example of this would be to create a Customer table and an Order table. The Order table could have a CHECK constraint that would prevent orders for a customer from exceeding a credit limit defined for the customer in the Customer table.


class <Jet definition>

class

The formal definition of an object. The class acts as the template from which an instance of an object is created at run time. The class defines the properties of the object and the methods used to control the object's behavior.


client batch cursor library <Jet definition>

client batch cursor library

A library that provides client-side cursor support for ODBCDirect database applications. This library supports all four types of cursors (keyset, static, dynamic, and forward-only) and provides a number of other features including the ability to dissociate connections and perform optimistic batch updates.


clustered index <Jet definition>

clustered index

The physical order of rows is the same as the indexed order of rows.


collection <Jet definition>

collection

An object that contains a set of related objects. An object's position in the collection can change whenever a change occurs in the collection; therefore, the position of any specific object in the collection may vary.


collision <Jet definition>

collision

A conflict that occurs during a batch update.

A collision occurs when a client reads data from the server and then attempts to modify that data in a batch update, but before the update attempt is actually executed another client changes the original server data. In this situation, the first client is attempting to modify server data without knowing what data actually exists on the server.


column <Jet definition>

column

The visual representation of a field in a grid. A column defines the data type, size, and other attributes of one field of a row (record) of data. All columns taken as a set define a row (record) in the database. An individual column contains data related in type and purpose throughout the table; that is, a column's definition does not change from row to row.


column-level tracking <Jet definition>

column-level tracking

Column-level tracking is a mechanism where each column in a row participates individually in conflict determination and resolution. If more than one replica modifies the same row, but each replica modifies a unique column, no conflict will occur and all changes will be merged.


commit <Jet definition>

commit

To accept a pending transaction. If you use transaction processing and begin a transaction using DAO, ADO, or SQL, none of the changes made in the transaction are written to the database until you commit, or accept, the transaction.


compound query <Jet definition>

compound query

A query that is composed of at least one action query (a query that copies or changes data) and at least one select query (a query that returns a Recordset without changing data). In DAO, a compound query is created by putting two or more SQL statements (separated by semicolons) in the SQL property of a QueryDef object.


connection string <Jet definition>

connection string

A string used to define the source of data for an external database. The connection string is usually assigned to the Connect property of a QueryDef, TableDef, Connection, or Database object or as an argument to the OpenDatabase method.


consistent <Jet definition>

consistent

The state of a multiple-table Recordset object that allows you to perform only updates that result in a consistent view of the data. For example, in a Recordset that is a join of two or more tables (a one-to-many relationship), a consistent query would not allow you to set the many-side key to a value that is not in the one-side table.


constant <Jet definition>

constant

A named item that retains a constant value throughout the execution of a program, as opposed to a variable, whose value can change during execution. Each host application can define its own set of constants. Additional constants may be defined by the user with the Const statement. Constants can be used anywhere in your code in place of actual values. A constant may be a string or numeric literal, another constant, or any combination that includes arithmetic or logical operators except the Is statement and exponentiation. For example:

Const strdb = "c:\Program Files\Microsoft Office\Access\Samples\Northwind.mdb"


constraint <Jet definition>

constraint

A limitation of the possible values that users can enter into a field. The ANSI SQL DDL CHECK constraint has been added to Microsoft® Jet version 4.X when going through the Microsoft OLE DB Provider for Jet. The CHECK constraint allows for the creation of business rules that span an entire table or multiple other tables.


copy buffer <Jet definition>

copy buffer

A location created by the Microsoft® Jet database engine for the contents of a record that is open for editing. The Edit method copies the current record to the copy buffer; the AddNew method clears the buffer for a new record and sets the default values; and the Update method saves the data from the copy buffer to the database, replacing the current record or inserting the new record. Any statement that resets or moves the current record pointer discards the copy buffer. For example, using the MoveNext method or changing the Index property of a table would discard the contents of the copy buffer.


correlation name <Jet definition>

correlation name

The ANSI definition of a name that refers to a column in a table or view (stored query). Also referred to as an alias name.


AutoNumber data type <Jet definition>

AutoNumber data type

A field attribute that automatically stores a unique number for each record as it is added to a table. An AutoNumber field uses the Long data type and has its Attributes property set to dbAutoIncrement. Numbers generated by an AutoNumber field cannot be modified unless special permission has been granted to the table through either the Grant or Revoke statements in SQL DDL syntax. The AutoNumber field is also known as a Counter or Identity data type.

Note For replicated tables in replicated databases, an AutoNumber field is not incremented by 1. Instead, it is assigned a random value between -2,000,000,000 and 2,000,000,000.

See Also

Identity attribute


criteria <Jet definition>

criteria

A set of limiting conditions, such as = "Denmark" (meaning equal to Denmark) or > 30000, used in creating a query or filter to show a specific set of records.


crosstab query <Jet definition>

crosstab query

A query that calculates a sum, average, count, or other type of total on records, and then groups the result by two types of information — one down the left side of a grid (row headings) and the other across the top (column headings). For example, the Quarterly Orders by Product query in the Northwind sample database is a crosstab query.


control character <Jet definition>

control character

Any key combination that begins with the CTRL or ESC key.


Currency data type <Jet definition>

Currency data type

A data type that is useful for calculations involving money or for fixed-point calculations in which accuracy is extremely important. This data type is used to store numbers with up to 15 digits to the left of the decimal point and 4 digits to the right. Because the Currency data type uses discrete values for all amounts, binary round-off is not a factor when calculating totals.


current database <Jet definition>

current database

The Database object returned by the CurrentDB( ) function. A reference of DBEngine.Workspaces(0).Databases(0) returns the first database opened. This concept applies only to Microsoft® Access.


current index <Jet definition>

current index

For an indexed table-type Recordset object, the index most recently set with the Index property. This index is the basis for ordering records in a table-type Recordset, and is used by the Seek method to locate records. A Recordset object can have more than one index but can use only one index at a time (although a TableDef object may have several indexes defined on it). The Microsoft Jet database engine may use more than one index to evaluate a query.


current record <Jet definition>

current record

The record in a Recordset object that you can use to modify or examine data. Use the Move methods to reposition the current record in a recordset. Use the Find methods (with a dynaset- or snapshot-type Recordset object) or the Seek method (with a table-type Recordset object) to change the current record position according to specific criteria.

Only one record in a Recordset can be the current record; however, a Recordset may have no current record. For example, after a dynaset-type Recordset record has been deleted, or when a Recordset has no records, the current record is undefined. In this case, operations that refer to the current record result in a trappable error.


current transaction <Jet definition>

current transaction

All changes made to a Recordset object after you use the last BeginTrans method and before you use the Rollback or CommitTrans method.


Data Access Objects (DAO) <Jet definition>

Data Access Objects (DAO)

A programming interface to access and manipulate database objects.


data access object <Jet definition>

DAO object

An object that is defined by the Data Access Objects (DAO) library. You can use DAO objects, such as the Database, TableDef, Recordset, and QueryDef objects, to represent objects that are used to organize and manipulate data, such as tables and queries, in code.


database engine <Jet definition>

database engine

That part of the database system that retrieves data from and stores data in user and system databases.


DDL (Data Definition Language) <Jet definition>

DDL (Data Definition Language)

The language used to describe attributes of a database, especially tables, fields, indexes, and storage strategy. ANSI defines this to have the tokens CREATE, DROP, and ALTER.


data-definition query <Jet definition>

data-definition query

An SQL-specific query that can create, alter, or delete a table, or create or delete an index in a database. ANSI defines these as DDL queries and uses the tokens CREATE, DROP, and ALTER.

See Also

DDL (Data Definition Language)


data source <Jet definition>

data source

A named Open Database Connectivity (ODBC) resource that specifies the location, driver type, and other parameters needed by an ODBC driver to access an ODBC database. A data source can be any source of database information.


data type <Jet definition>

data type

The characteristics of a variable that determine what kind of data the variable can hold. Data types include Big Integer, Binary, Byte, Boolean, Char, Currency, Date, Decimal, Double, Float, GUID, Integer, Long, Long Binary (OLE Object), Memo, Numeric, Single, String, Text, Time, TimeStamp, VarBinary, Variant (default), user-defined types (created with the Type statement), and object data types, which include host-defined object data types and DAO object types.


date literal <Jet definition>

date literal

Any sequence of characters with a valid format that is surrounded by number signs (#). Valid formats include the date format specified by the locale settings for your code or the universal date format.

For example, #12/31/92# is the date literal that represents December 31, 1992 where English-U.S. is the locale setting for your application. Use date literals to maximize portability across national languages.


dates and times <Jet definition>

dates and times

Dates and times are stored internally as different parts of a real number.

The value to the left of the decimal represents a date between December 30, 1899 and December 30, 9999, inclusive. Negative values represent dates prior to December 30, 1899.

The value to the right of the decimal represents a time between 0:00:00 and 23:59:59, inclusive. Midday is represented by .5.


Decimal data type <Jet definition>

Decimal data type

A data type that stores a signed, exact numeric value with precision p and scale s (1 ≤ p ≤15; 0 ≤ s ≤ p).


default workspace <Jet definition>

default workspace

The Workspace object that DAO automatically establishes when your application first references any DAO object. This Workspace is referenced by DBEngine.Workspaces(0) or simply Workspaces(0).


delete query <Jet definition>

delete query

An action query that deletes a set of rows that match the criteria you specify. A delete query does not return rows.


design time <Jet definition>

design time

The time during which you build an application in the development environment by adding controls, setting control or form properties, and so on. In contrast, during run time, you interact with the application as a user would.


destination field <Jet definition>

destination field

A field in a query that will contain the results of your query.


direct synchronization <Jet definition>

direct synchronization

A type of synchronization that occurs when the two replicas can be opened simultaneously during the synchronization process.


DLL (dynamic-link library) <Jet definition>

DLL (dynamic-link library)

A set of routines that can be called from procedures and are loaded and linked into your application at run time.


Double data type <Jet definition>

Double data type

A fundamental data type that holds double-precision floating-point numbers in IEEE format. A Double variable is stored as a 64-bit (8-byte) number ranging in value from -1.79769313486231E308 to -4.94065645841247E-324 for negative values, from 4.94065645841247E-324 to 1.79769313486231E308 for positive values, and 0.


dynamic cursor <Jet definition>

dynamic cursor

A dynamic set of rows that you can use to add, change, or delete rows from an underlying database table or tables. A dynamic cursor can contain columns from one or more tables in a database. Membership is not fixed.


dynaset <Jet definition>

dynaset

A type of Recordset object that returns a dynamic set of pointers to live database data. Like a table- or a snapshot-type Recordset, a dynaset returns data in records (rows) and fields (columns). Unlike a table-type Recordset, a dynaset-type Recordset can be the result of a query that joins two or more tables. The records in a dynaset-type Recordset object are updatable if the Updatable property of the Recordset is True, the Field being changed is updatable, and the data page containing the current record is not locked. The data page is locked when the Update method is used (when the LockEdits property is False), or the Edit method is used (when the LockEdits property is True).


equi-join <Jet definition>

equi-join

A join in which records from two tables are combined and added to the Recordset object only when there are equal values in the joined fields. Also referred to as an inner-join.


exclusive <Jet definition>

exclusive

A type of access that protects data in a database shared over a network. When you open a database in exclusive mode, you prevent others from opening the database.


expression <Jet definition>

expression

Any combination of operators, constants, literal values, functions, and names of fields, controls, and properties that evaluates to a single value. You can use expressions as settings for many properties and action arguments, to set criteria, or define calculated fields in queries.


external database <Jet definition>

external database

Either an ODBC database such as Microsoft® SQL Server™ that resides on a remote server, or one of the external databases such as Paradox, dBASE, Microsoft FoxPro®, Microsoft Excel, Microsoft Access, Lotus 1-2-3, HTML, and Text.


external table <Jet definition>

external table

A table in a database outside the open Microsoft® Jet database. An external table may take the form of another file or it may be a table in another relational database.


field <Jet definition>

field

A category of information stored in a table in a database — a column of data. An element of a database table that contains a specific item of information, such as last name.


field properties <Jet definition>

field properties

Attributes of a field that determine what kind of data it contains. Size and Type are examples.


filter <Jet definition>

filter

A set of criteria applied to records in order to create a subset of the records.


Float data type <Jet definition>

Float data type

A data type that stores a signed, approximate numeric value with mantissa precision 15 (zero or absolute value 10-308 to 10308).


foreign key <Jet definition>

foreign key

One or more table fields that refer to the primary key field or fields in another table. A foreign key indicates how the tables are related — the data in the foreign key and primary key fields must match. For example, a list of valid part numbers would contain a foreign key to an inventory table containing references to valid part numbers. Used when establishing referential integrity for a database.


foreign table <Jet definition>

foreign table

A table that provides a foreign key to another table in the database. Generally, you use a foreign table to establish or enforce referential integrity. The foreign table is usually on the "many" side of a one-to-many relationship. An example of a foreign table is a table of customer orders.


form <Jet definition>

form

A window or dialog box. Forms are containers for controls. A multiple-document interface (MDI) form can also act as a container for child forms and some controls.


forward-only cursor <Jet definition>

forward-only cursor

A result set where the current position can only move forward by a specified number of records, or to the very last record. The current position cannot be moved back to the beginning of the result set or to previous records. The cursor membership, order, and values are generally fixed when the cursor is opened. If other users update, delete, or insert rows, the cursor does not reflect these changes until you close and reopen it.


forward scroll <Jet definition>

forward scroll

Move toward the end (EOF) of a Recordset object.


forward-only-type Recordset <Jet definition>

forward-only – type Recordset

A Recordset object in which records can be searched only from beginning to end; the current record position cannot be moved back to the first record. Forward-only – type recordsets reduce processing overhead on remote databases. For example, you can use a forward-only – type Recordset on a linked remote table to quickly process data in one pass, such as when you are building a customized report.


FTP <Jet definition>

FTP

File Transfer Protocol. A protocol that makes it possible for a user to transfer files from one location to another over the Internet. URLs of files on FTP servers begin with ftp://.


Function procedure <Jet definition>

Function procedure

A procedure that performs a specific task within a Microsoft® Visual Basic® program and returns a value. A Function procedure begins with a Function statement and ends with an End Function statement.


group <Jet definition>

group

A collection of user accounts in a Workgroup object, identified by group name and personal identifier (PID). Permissions assigned to a group apply to all users in the group.


GUID data type <Jet definition>

GUID data type

Globally Unique Identifier/Universally Unique Identifier. A unique identification string used with remote procedure calls. Every interface and object class uses a GUID for identification. A GUID is a 128-bit value. For example, 12345678-1234-1234-1234-123456789ABC is a syntactically correct GUID. The GUIDs on the client and server must match for the client and server to bind. Vendors of objects can request that Microsoft allocate one or more sets of 256 GUIDs for their exclusive use. Alternatively, if you have a network card, you can run a tool named Uuidgen.exe, which provides a set of 256 GUIDs based on the time of day, the date, and a unique number contained in your network card.


HTTP <Jet definition>

HTTP

Hypertext Transfer Protocol. The behind-the-scenes Internet protocol that delivers information by way of the World Wide Web. The protocol makes it possible for a user to use a client program to enter a URL (or click a hyperlink) and retrieve text, graphics, sound, and other digital information from a Web server. URLs of files on Web servers begin with http://.


hyperlink data type <Jet definition>

hyperlink data type

A field data type you use for fields that will store hyperlinks. Hyperlink fields contain text or combinations of text and numbers stored as text that are used as a hyperlink address. A hyperlink address can have up to three parts (each part can contain up to 2048 characters and uses the syntax:

displaytext#address#subaddress


Identity attribute <Jet definition>

Identity attribute

Added to allow for syntactical equivalence to SQL server. Only available when using SQL DDL from the Microsoft® OLE DB Provider for Jet. This data type has the same functionality as the Counter and AutoNumber data types. It is a synonym and has no additional functionality.

See Also

AutoNumber field


inconsistent <Jet definition>

inconsistent

The state of a multiple-table Recordset object that enables you to update all fields (columns). For example, in a Recordset created by joining two tables in a one-to-many join (as in a Customers and Orders table), you can update Orders.CustomerID so that it does not match Customers.CustomerID, unless referential integrity disables the update.


increment <Jet definition>

increment

Optional parameter used with the Counter or Identity data types. Available in SQL DDL only when utilizing the Microsoft® OLE DB Provider for Jet. This is the value that is used to assign the next value of a new row in a table that contains a Counter or Identity data type. The increment is the second of the two optional parameters to the Counter or Identity data types.

See Also

seed


index <Jet definition>

index

A dynamic cross-reference of one or more table data fields (columns) that permits faster retrieval of specific records from a table. As records are added, changed, or deleted, the database management system automatically updates the index to reflect the changes.

When used with a table-type Recordset object, the current index determines the order in which data records are returned to the Recordset. A table may have several indexes defined for its data.

A DAO Index object represents an index for a TableDef object.


indirect synchronization <Jet definition>

indirect synchronization

A type of synchronization that occurs when one Synchronizer leaves changes in a dropbox folder for another Synchronizer to pick up and apply to the replica it manages.


inner join <Jet definition>

inner join

A join in which records from two tables are combined and added to a Recordset only if the values of the joined fields meet a specified condition. For instance, an equi-join is an inner join in which the values of the joined fields must be equal.


installable ISAM <Jet definition>

installable ISAM

A driver you can specify that allows access to external database formats such as dBASE, Microsoft® Excel, and Paradox. ISAM is an acronym for Indexed Sequential Access Method. The Microsoft Jet database engine installs (loads) these ISAM drivers when referenced by your application. The location of these drivers is maintained in the Microsoft Windows® Registry.


instance <Jet definition>

instance

Any one of a set of objects sharing the same class. For example, multiple instances of a Form class share the same code and are loaded with the same controls with which the Form class was designed. During run time, the individual properties of controls on each instance can be set to different values.


Integer data type <Jet definition>

Integer data type

A fundamental data type that holds integer numbers. An Integer variable is stored as a 16-bit (2-byte) number ranging in value from -32,768 to 32,767.


Internet <Jet definition>

Internet

A worldwide network of thousands of smaller computer networks and millions of commercial, educational, government, and personal computers. The Internet is like an electronic city with virtual libraries, storefronts, business offices, art galleries, and so on.


internet synchronization <Jet definition>

internet synchronization

A type of synchronization that relies on a series of message exchanges between replicas that are left in a dropbox folder. Only the replica managed by the Synchronizer on the Internet Server has a dropbox. This dropbox is accessible via an HTTP or FTP connection.


intranet <Jet definition>

intranet

A network within an organization that uses Internet technologies (such as the HTTP or FTP protocols). You can use an intranet to navigate between objects, documents, Web pages, and other destinations using hyperlinks.


intrinsic constant <Jet definition>

intrinsic constant

A constant provided by an application. For example, Data Access Objects (DAO) constants are listed in the DAO object library and can be viewed by using the Object Browser.


Microsoft Jet-connected ODBC data source <Jet definition>

Microsoft Jet-connected ODBC data source

An ODBC data source that is accessed by using Data Access Objects (DAO) and the Microsoft® Jet database engine.


join <Jet definition>

join

A database operation that combines some or all records from two or more tables, such as an equi-join, inner-join, outer join, or self-join. Generally, a join refers to an association between a field in one table and a field of the same data type in another table. You create a join with an SQL statement.

When you define a relationship between two tables, you create a join by specifying the primary and foreign table fields. When you add a table to a query, you need to create a join between appropriate fields in the SQL statement that defines the query.


keyset cursor <Jet definition>

keyset cursor

A set of rows that you can use to add, change, or delete rows from an underlying database table or tables. Movement within the keyset is unrestricted. A keyset cursor can contain columns from one or more tables in a database. Membership is fixed.


left join <Jet definition>

left join

A left outer join includes all of the records from the first (left) of two tables, even if there are no matching values for records in the second (right) table.


left outer join <Jet definition>

left outer join

An outer join in which all the records from the left side of the LEFT JOIN operation in the query's SQL statement are added to the Recordset object, even if there are no matching values in the joined field from the table on the right. Records from the table on the right are combined with those from the table on the left only when there are matching values in the joined fields. When a left-side record has no match, a row of Null values is joined on the right side.


linked table <Jet definition>

linked table

A table in another database linked to a Microsoft® Jet database. Data for linked tables remains in the external database where it can be manipulated by other applications. (Formerly known as attached tables.)


locked <Jet definition>

locked

The condition of a data page, Recordset object, or Database object that makes it read-only to all users except the one who is currently entering data in it.


Long Binary data type <Jet definition>

Long Binary data type

A type of field that can hold 2.14 GB of data. Long Binary fields can contain any type of binary data. Also known as an OLE Object data type in Microsoft® Access.


Long data type <Jet definition>

Long data type

A fundamental data type that holds long-integer numbers. A Long variable is stored as a 32-bit (4-byte) number ranging in value from -2,147,483,648 to 2,147,483,647.


make-table query <Jet definition>

make-table query

An action query that creates a new table from the Recordset object of an existing query.


many-only table <Jet definition>

many-only table

A table that does not appear as the "one" side of any join in a query.


Memo data type <Jet definition>

Memo data type

A field data type. Such fields can contain up to 2.14 GB of text data.


message <Jet definition>

message

A packet of information passed from one application to another.


method <Jet definition>

method

A procedure similar to a function that operates on specific objects.


Microsoft Jet database <Jet definition>

Microsoft Jet database

A database created with the Microsoft® Jet database engine. The file name extension for a Microsoft Jet database is .mdb.


Microsoft Jet workspace <Jet definition>

Microsoft Jet workspace

A workspace that uses the Microsoft® Jet database engine to access a data source. The data source can be a Microsoft Jet database file (.mdb), an ODBC database, such as a Paradox database, or an ISAM database.


field data types <Jet definition>

field data types

The following table lists the Field data types.

DAO Field data type | Constant
Big Integer | DbBigInt
Binary | DbBinary
Boolean | DbBoolean
Byte | DbByte
Char | DbChar
Currency | DbCurrency
Date/Time | DbDate
Decimal | DbDecimal
Double | DbDouble
Float | DbFloat
GUID | DbGUID
Integer | DbInteger
Long | DbLong
Long Binary (OLE Object) | DbLongBinary
Memo | DbMemo
Numeric | DbNumeric
Single | DbSingle
Text | DbText
Time | DbTime
TimeStamp | DbTimeStamp
VarBinary | DbVarBinary


Microsoft Jet database engine <Jet definition>

Microsoft Jet database engine

A database management system that retrieves data from and stores data in user and system databases. The Microsoft® Jet database engine can be thought of as a data manager component with which other data access systems, such as Microsoft Access and Microsoft Visual Basic®, are built.


multiuser database <Jet definition>

multiuser database

A database that permits more than one user to access and modify the same set of data at the same time. In some cases, the additional user may be another instance of your application or another application running on your system that accesses the same data as some other application.


normalize <Jet definition>

normalize

To minimize the duplication of information in a relational database through effective table design.


Null <Jet definition>

Null

A value that indicates missing or unknown data. Null values can be entered in fields for which information is unknown and in expressions and queries. In Visual Basic, the Null keyword indicates a Null value. Some fields, such as those defined as containing the primary key, cannot contain Null values.


null field <Jet definition>

null field

A field containing no characters or values. A null field is not the same as a zero-length string ("") or a field with a value of 0. A field is set to null when the content of the field is unknown. For example, a Date Completed field in a task table would be left null until a task is completed.


Numeric data type <Jet definition>

Numeric data type

A data type that stores a signed, exact numeric value with precision p and scale s (1 ≤ p ≤15; 0 ≤ s ≤ p).


numeric expression <Jet definition>

numeric expression

Any expression that results in a number. This can be any combination of variables, constants, functions, and operators that evaluates to a number.


Object Browser <Jet definition>

Object Browser

A dialog box you can use to examine the contents of an object library to get information about the objects provided.


object expression <Jet definition>

object expression

An expression that specifies a particular object. This expression can include any of the object's containers. For example, if your application has an Application object that contains a Document object that contains a Text object, the following are valid object expressions:

Application.Document.Text

Application.Text

Document.Text

Text


object library <Jet definition>

object library

A dynamic-link library (DLL) with one or more type library resources that typically has the extension .olb. You can use the Object Browser to examine the contents of an object library to get information about the objects provided.


object variable <Jet definition>

object variable

A variable that contains a reference to an object.


ODBC (Open Database Connectivity) <Jet definition>

ODBC (Open Database Connectivity)

A standard protocol that permits applications to connect to a variety of external database servers or files. ODBC drivers used by the Microsoft® Jet database engine permit access to Microsoft SQL Server™ and several other external databases.

The ODBC application programming interface (API) may also be used to access ODBC drivers and the databases they connect to without using the Microsoft Jet database engine.


ODBC data source <Jet definition>

ODBC data source

A term used to refer to a database or database server used as a source of data. ODBC data sources are referred to by their Data Source Name (DSN). Data sources can be created by using the Microsoft® Windows® Control Panel or the RegisterDatabase method.


ODBC driver <Jet definition>

ODBC driver

A dynamic-link library (DLL) used to connect a specific Open Database Connectivity data source with another (client) application.


ODBC Driver Manager <Jet definition>

ODBC Driver Manager

An application that manages connections between ODBC-enabled data sources and the drivers used to access them.


OLE <Jet definition>

OLE

Microsoft's object-based technology that enables you to create applications that contain components from various other applications.


ActiveX object <Jet definition>

ActiveX object

An object that is exposed to other applications or programming tools through Automation (formerly OLE Automation) interfaces. For example, Microsoft® Access can create and manipulate Microsoft ActiveX® objects within Microsoft Word or Microsoft Excel.


OLE Object data type <Jet definition>

OLE Object data type

A field data type you use for objects created in other applications that can be linked or embedded in a Microsoft® Jet database. For example, you could use an OLE Object field to store a collection of pictures.


one-to-many relationship <Jet definition>

one-to-many relationship

An association between two tables in which:

  • The primary key value of each record in the primary table corresponds to the value in the matching field or fields of many records in the related table.
  • The primary key value of each record in the related table corresponds to the value in the matching field or fields of one and only one record in the primary table.


one-to-one relationship <Jet definition>

one-to-one relationship

An association between two tables in which:

  • The primary key value of each record in the primary table corresponds to the value in the matching field or fields of one and only one record in the related table.
  • The primary key value of each record in the related table corresponds to the value in the matching field or fields of one and only one record in the primary table.


optimistic <Jet definition>

optimistic

A type of locking in which the data page containing one or more records, including the record being edited, is unavailable to other users only while the record is being updated by the Update method, but is available between the Edit and Update methods. Optimistic locking is used when accessing ODBC databases or when the LockEdits property of the Recordset object is set to False.


outer join <Jet definition>

outer join

A join in which all the records from one table are added to the Recordset object, even if there are no matching values in the joined field from the second table. Records from the second table are combined with those from the first table only when there are matching values in the joined fields. Null records are joined when there is no match.


page <Jet definition>

page

A portion of the database in which record data is stored. Depending on the size of the records, a page may contain more than one record. In Microsoft® Jet databases (.mdb), a page is 2048 (2K) bytes in length. Jet 4.X file formats have a 4K page (4096 bytes).


parameter <Jet definition>

parameter

An element containing a value that you can change to affect the results of the query. For example, a query returning data about an employee might have a parameter for the employee's name. You can then use one QueryDef object to find data about any employee by setting the parameter to a specific name before running the query.

Using the Microsoft® OLE DB Provider for Jet in Microsoft Jet version 4.X, parameters can be exposed from procedures using the ANSI question mark (?) parameter markers. Using SQL syntax, you can create the equivalent to a QueryDef.


parameter query <Jet definition>

parameter query

A query that requires you to provide one or more criteria values, such as Redmond for City, before the query is run. A parameter query is not, strictly speaking, a separate kind of query; rather, it extends the flexibility of other queries.

Using the Microsoft® OLE DB Provider for Jet in Microsoft Jet version 4.X, parameters can be exposed from procedures using the ANSI question mark (?) parameter markers. Using SQL syntax, you can create the equivalent to a QueryDef.


parse <Jet definition>

parse

To identify the parts of a statement or expression and then validate those parts against the appropriate language rules.


partial replica <Jet definition>

partial replica

A database that contains only a subset of the records in a full replica. With a partial replica, you can set filters and identify relationships that define which subset of the records in the full replica should be present in the database.


pass-through query <Jet definition>

pass-through query

An SQL-specific query you use to send commands directly to a SQL database server (such as Microsoft® SQL Server™). With pass-through queries, you work with the tables on the server instead of linking them. Pass-through queries are used to execute SQL queries and system-specific commands written by using SQL dialects known only to the server.

A pass-through query may or may not return records. If it does, they are always returned in a snapshot.


permission <Jet definition>

permission

One or more attributes that specify what kind of access a user has to data or objects in a database. For example, if a user has read data permission for a table or query, the user can view or retrieve but not edit data in the table or query.


persistent object <Jet definition>

persistent object

An object stored in the database; for example, a database table or QueryDef object. Dynaset-type or snapshot-type Recordset objects are not considered persistent objects because they are created in memory as needed.


pessimistic <Jet definition>

pessimistic

A type of locking in which the page containing one or more records, including the record being edited, is unavailable to other users when you use the Edit method, and remains unavailable until you use the Update method. Pessimistic locking is enabled when the LockEdits property of the Recordset object is set to True.


personal identifier (PID) <Jet definition>

personal identifier (PID)

A case-sensitive alphanumeric string 4-20 characters long that the Microsoft® Jet database engine uses in combination with the account name to identify a user or group in a Workgroup object. You provide the PID and the account name when you create a new user or group.


primary key <Jet definition>

primary key

One or more fields whose value or values uniquely identify each record in a table. In a relationship, a primary key is used to refer to specific records in one table from another table. A primary key is called a foreign key when it is referred to from another table. You can have only one primary key. An Employees table, for example, could use the social security number for the primary key.


primary table <Jet definition>

primary table

The "one" side of two related tables in a one-to-many relationship with a foreign table. Generally, a primary key table is used to establish or enforce referential integrity.


priority <Jet definition>

priority

A long value indicating the priority of the replica for use during conflict resolution. A valid priority value for a Global replica is between 0 and 100, inclusive. Local and Anonymous replicas always have a priority of 0. During synchronization, if a conflict occurs, the replica with the highest priority will win. The losing data will be logged in the conflict table.


procedure <Jet definition>

procedure

Similar to a view except that the SQL syntax can allow for SELECT statements (row returning queries) to pass parameters and allow for DML (non-row returning queries) UPDATE, INSERT, DELETE, and SELECT INTO. Literally the same as a querydef, except that it can be created from SQL syntax without the use of the DAO object model.


procedural query <Jet definition>

procedural query

An SQL statement that executes a stored procedure.


property <Jet definition>

property

A named attribute of an object. Properties define object characteristics such as size, color, and screen location, or the state of an object, such as enabled or disabled.


pseudo index <Jet definition>

pseudo index

A dynamic cross-reference of one or more table data fields (columns) that permits an ODBC table (server table) without a unique index to be edited. A pseudo index is not an actual index on the server table, but a cross-reference that the Microsoft® Jet database engine can use to support table updates. A pseudo index is necessary only if an ODBC table does not have a unique index, which allows the table to be updated. You do not need a pseudo index if the table already has a unique index or if there is no need to update the table. (Tables cannot have a unique index if they were intended to be read-only.) In previous versions, pseudo indexes were called index specifications.


query <Jet definition>

query

A formalized instruction to a database to either return a set of records or perform a specified action on a set of records as specified in the query. For example, the following SQL query statement returns records:

SELECT CompanyName FROM Publishers WHERE Region = 'NY'

You can create and run select, action, crosstab, parameter, and SQL-specific queries.


read-only <Jet definition>

read-only

A type of access to data whereby information can be retrieved but not modified.


record <Jet definition>

record

A set of related data about a person, place, event, or other item. Table data is stored in records (rows) in the database. Each record is composed of a set of related fields (columns). Each field defines one attribute of information for the record. Taken together, a record defines one specific unit of retrievable information in a database.

A record is also known as a row.

See Also

rowdadefRow


referential integrity <Jet definition>

referential integrity

Rules that you set to establish and preserve relationships between tables when you add, change, or delete records. Enforcing referential integrity prohibits users from adding records to a joined table for which there is no primary key, changing values in a primary table that would result in orphaned records in a joined table, and deleting records from a primary table when there are matching related records.

If you select the dbRelationDeleteCascade or dbRelationUpdateCascade option for a relationship, the Microsoft® Jet database engine allows changes and deletions, but changes or deletes related records to make sure the rules are still enforced.

Microsoft Jet version 4.X, through the Microsoft OLE DB Provider for Jet, exposes a much richer set of ANSI SQL and also exposes the ANSI cascade NULL referential action.


relationship <Jet definition>

relationship

An association established between common fields (columns) in two tables. A relationship can be one-to-one, many-to-many, or one-to-many.


requery <Jet definition>

requery

To rerun a query to reflect changes to the records, retrieve newly added records, and eliminate deleted records.


reserved word <Jet definition>

reserved word

A word that is part of a language, such as the Microsoft® Jet database engine SQL language. Reserved words include the names of statements, predefined functions and data types, methods, operators, and objects. Examples include SELECT, UPDATE, BETWEEN, SET, and INSERT. Do not use reserved words for variable or object names.

When using the Microsoft OLE DB Provider for Jet, the reserved word list for Microsoft Jet version 4.X has been increased to be compliant with ANSI SQL-92.


right join <Jet definition>

right join

A right outer join includes all of the records from the second (right) of two tables, even if there are no matching values for records in the first (left) table.

For example, you could use LEFT JOIN with the Departments (left) and Employees (right) tables to select all departments, including those that have no employees assigned to them. To select all employees, including those who are not assigned to a department, you would use RIGHT JOIN.


right outer join <Jet definition>

right outer join

An outer join in which all the records from the right side of the RIGHT JOIN operation in the query's SQL statement are added to the Recordset object, even if there are no matching values in the joined field from the left table. Records from the left table are combined with those from the right table only when there are matching values in the joined fields.


rollback <Jet definition>

rollback

When using the Microsoft® OLE DB Provider for Jet, you can now start (BeginTrans), commit (CommitTrans), or rollback (RollBack) a transaction without going through the object model DAO or ADO. With rollback (RollBack), a transaction that was started (BeginTrans) can be ended or removed.


row <Jet definition>

row

A set of related columns or fields used to hold data. A row is synonymous with a record in the Microsoft® Jet database engine. A table is composed of zero or more rows of data.


row-level locking <Jet definition>

row-level locking

A new feature in Microsoft® Jet version 4.X that allows a user to lock a row instead of a page when updating or deleting a row. Row-level locking is not implemented on columns that are indexed or LV (long value) data types (Memo).


row-level tracking <Jet definition>

row-level tracking

Row-level tracking is a mechanism where the entire row participates in conflict determination and resolution. A conflict will occur if more than one replica modifies the same row, even if the changed data exists in different columns of that row.


run-time error <Jet definition>

run-time error

An error that occurs when code is running. A run-time error results when a statement attempts an invalid operation.


run time <Jet definition>

run time

The time when code is running. During run time, you interact with the code as a user would.


scope <Jet definition>

scope

The attribute of a variable or procedure that determines which sections of which modules recognize it. There are three levels of scope: public, module, and procedure. Variables that you declare with Public can be accessed by any module, while variables that you declare in a specific module can be used only within that module. Also, variables that you declare in a Sub or Function procedure can be used only in that particular procedure.


secure workgroup <Jet definition>

secure workgroup

A Microsoft® Jet database Workgroup object to which users log on with a user name and password and in which access to database objects is restricted according to permissions specified for user accounts and groups.


security <Jet definition>

security

A set of features used to specify or restrict the access that specified users or user groups have to data and objects in a database.


seed <Jet definition>

seed

Optional parameter used with the Counter or Identity data types. Available in SQL DDL only when utilizing the Microsoft® OLE DB Provider for Jet. Can also be referred to as the starting value. The seed is the first of the two optional parameters to the Counter or Identity data types.

The following SQL statement is an example with the parameters:

CREATE TABLE Customers (CustId IDENTITY (100, 10) CONSTRAINT pkCustomers PRIMARY KEY, CFrstNm VARCHAR(10), CLstNm VARCHAR(15));

The column CustId in the first row will have a value of 100. The second row will have a value of 110.

When the optional parameters are utilized and do not contain values of (1,1), Jet will not reset the seed to the maximum value in the table. This behavior is different than in previous versions of Jet. If the optional parameters are not passed or a value of (1,1) is not used, when the database is compacted the seed will be reset to the maximum value of the Counter or Identity column in the table.

See Also

increment


select query <Jet definition>

select query

A query that asks a question about the data stored in your tables and returns a Recordset object without changing the data. Once the Recordset data is retrieved, you can examine and make changes to the data in the underlying tables. In contrast, action queries can make changes to your data, but they do not return data records.


self-join <Jet definition>

self-join

A join in which records from a table are combined with other records from the same table when there are matching values in the joined fields. A self-join can be an inner join or an outer join. A self-join is useful when you ask hierarchical questions, such as a query that shows all the managers and the people who report to them.


server <Jet definition>

server

The database management system designed to share data with client applications; servers and clients are often connected over a network. A database server usually contains and manages a central repository of data that remote client applications can retrieve and manipulate.


server-side cursor <Jet definition>

server-side cursor

Cursors that reside on the server, as opposed to residing on the client computer. While client-side cursors copy the cursor to the workstation, server-side cursors use the resources of the database server to maintain the cursors.


session <Jet definition>

session

A session delineates a sequence of operations performed by the Microsoft® Jet database engine. A session begins when a user logs on and ends when a user logs off. All operations performed during a session form one transaction scope and are subject to permissions determined by the logon user name and password. Sessions are implemented as Workspace objects by DAO.


Short data type <Jet definition>

Short data type

A Microsoft® Jet database engine fundamental data type that corresponds to the Integer data type defined by Microsoft Visual Basic® for Applications. A Short variable is stored as a 16-bit (2-byte) number ranging in value from -32,768 to 32,767.


Single data type <Jet definition>

Single data type

A fundamental data type that holds single-precision floating-point numbers in IEEE format. A Single variable is stored as a 32-bit (4-byte) number ranging in value from -3.402823E38 to -1.401298E-45 for negative values, from 1.401298E-45 to 3.402823E38 for positive values, and 0.


snapshot <Jet definition>

snapshot

A fixed copy of a set of records retrieved from the database and copied into memory. A snapshot derived from a Microsoft® Jet-connected data source cannot be updated. Snapshot-type Recordset objects can be created from a base table, a query, or another Recordset. All SQL pass-through queries return snapshots.


sort order <Jet definition>

sort order

A sequencing principle used to order data, alphabetically or numerically. The sort order can be either ascending or descending.


SQL-specific query <Jet definition>

SQL-specific query

A query that can be created only by writing an SQL statement. Subqueries and pass-through, union, and data-definition queries are SQL-specific queries.


SQL statement/string <Jet definition>

SQL statement/string

An expression that defines a Structured Query Language (SQL) command, such as SELECT, UPDATE, or DELETE, and may include clauses such as WHERE and ORDER BY. SQL strings and statements are typically used in queries, Recordset objects, and aggregate functions but can also be used to create or modify a database structure.


standard deviation <Jet definition>

standard deviation

A parameter that indicates the way in which a probability function is centered around its mean and that is equal to the square root of the moment in which the deviation from the mean is squared. Used to describe sets of values to determine how far the value varies from the arithmetic mean or average.


standard naming conventions <Jet definition>

standard naming conventions

A set of specific rules for naming DAO objects. Names can be up to 64 characters long and can include any combination of letters, numbers, spaces, and special characters except a period (.), an exclamation point (!), a backquote character (`), and brackets ([ ]). You also cannot use leading spaces or control characters (ASCII values 0 through 31).


static cursor <Jet definition>

static cursor

A result set where the membership, order, and values are generally fixed when the cursor is opened. If other users update, delete, or insert rows, the cursor does not reflect these changes until you close and reopen it.


string comparison <Jet definition>

string comparison

The use of an operator to determine whether one string is greater than or equal to another string. If you use Option Compare Text in the Declarations section of a module, string comparisons are not case-sensitive. If you use Option Compare Binary, comparisons are case-sensitive. If you use Option Compare Database, the comparison method is set by the current database.


String data type <Jet definition>

String data type

A fundamental data type that holds character information. A String variable is either fixed-length or variable-length and contains one character per byte. Fixed-length strings are declared to be a specific length and can contain 1 to approximately 64K (2^16) characters. Variable-length strings can be any length up to 2 billion (2^31) characters (approximately 64K [2^16] characters for Microsoft® Windows® version 3.1 and earlier), less a small amount of storage overhead.


string expression <Jet definition>

string expression

Any expression that evaluates to a sequence of contiguous characters. Elements of the expression can include a function that returns a string, a string literal, a string constant, a string variable, a string Variant, or a function that returns a string Variant (VarType 8).


Structured Query Language (SQL) <Jet definition>

Structured Query Language (SQL)

A language used in querying, updating, and managing relational databases. SQL can be used to retrieve, sort, and filter specific data to be extracted from the database.

You can use SQL SELECT statements anywhere a table name, query name, or field name is accepted. For example, you can use an SQL statement in place of a table name in the OpenRecordset method.


subquery <Jet definition>

subquery

A subquery is a SELECT statement nested inside a SELECT, SELECT...INTO, INSERT...INTO, DELETE, or UPDATE statement or inside another subquery.


syntax error <Jet definition>

syntax error

An error that occurs when you enter a line of code that Microsoft® Visual Basic® does not recognize.

Note Syntax rules for individual keywords are defined in the Syntax section of the associated Help topic. To get Help on a keyword from within the development environment, select the keyword and press F1.


system object <Jet definition>

system object

A database object defined by the Microsoft® Jet database engine, such as the table MSysIndexes.


table <Jet definition>

table

The basic unit of data storage in a relational database. A table stores data in records (rows) and fields (columns) and is usually about a particular category of things, such as employees or parts. Also called a base table.

A table-type Recordset is a logical representation of a base table in a database.


TEMP <Jet definition>

TEMP

A TEMP environment variable is set by your autoexec.bat file when you start your system. Generally, TEMP points to an area on your hard disk used by Microsoft® Windows® and other programs, like the Microsoft Jet database engine, to store information that does not need to be saved after you shut down your system. For example, the following line in your autoexec.bat file points the TEMP environment variable to the D:\TempArea folder:

SET TEMP=D:\TempArea


temporary disk <Jet definition>

temporary disk

The disk or directory, identified by the TEMP operating system environment variable, where the Microsoft® Jet database engine stores temporary files and result sets. Also known as a temporary drive. Although the TEMP environment variable can point to a RAM disk, this is not recommended.


Text data type with length specification <Jet definition>

Text(n) data type (with length specification)

A field data type. Text fields can contain up to 255 characters or the number of characters specified by the Size property of the Field object, whichever is less. If the Size property of the text field is set to 0, the text field can hold up to 255 characters of data.


Text data type without length specification <Jet definition>

Text data type (without length specification)

A field data type. Text fields defined without an explicit length are the same as a Memo field and can contain up to 2.14 GB of character data.


Time data type <Jet definition>

Time data type

A data type that stores a time value. The value is dependent on the clock setting of the data source.


transaction <Jet definition>

transaction

A series of changes made to a database's data and schema. Mark the beginning of a transaction with the BeginTrans statement, commit the transaction by using the CommitTrans statement, and undo all your changes since BeginTrans by using the Rollback statement.

Transactions are optional and can be nested up to five levels. Transactions increase the speed of operations that change data and enable you to reverse changes easily.

Transactions are global to the referenced database object's Workspace.


Unicode representation format <Jet definition>

Unicode representation format

A 16-bit character set managed by the Unicode Consortium that contains all of the characters needed to display every language in the world. Unicode is increasingly being used to facilitate multi-lingual operation of software.


union query <Jet definition>

union query

An SQL-specific select query that creates a snapshot-type Recordset object containing data from all specified records in two or more tables with any duplicate records removed. To include the duplicates, add the keyword ALL.

For instance, a union query of the Customers table and the Suppliers table results in a snapshot-type Recordset that contains all suppliers that are also customers.


unmanaged replica <Jet definition>

unmanaged replica

A replica that is not managed by a Synchronizer. Unmanaged replicas appear on the Synchronization window with a special icon. You cannot set synchronization schedules from an unmanaged replica, although they can be synchronized by another Synchronizer or through DAO code.


update <Jet definition>

update

The process that saves changes to data in a record. Until the record is saved, changes are stored in a temporary record called the copy buffer. The UPDATE clause in an SQL statement changes data values in one or more records (rows) in a database table.


update query <Jet definition>

update query

An action query that changes a set of records according to criteria you specify. An update query does not return any records.


user account <Jet definition>

user account

An account identified by a user name and personal identifier (PID) that is created to manage access to database objects in a Microsoft® Jet database Workgroup object.


validation <Jet definition>

validation

The process of checking whether entered data meets certain conditions or limitations.


validation properties <Jet definition>

validation properties

Properties used to set conditions on table fields and records. Validation properties include ValidationRule, Required, and AllowZeroLength.


validation rule <Jet definition>

validation rule

A rule that sets limits or conditions on what can be entered in one or more fields. Validation rules can be set for a Field or TableDef object. Validation rules are checked when you update a record containing fields requiring validation. If the rule is violated, a trappable error results.


VarBinary data type <Jet definition>

VarBinary data type

A data type that stores variable-length binary data. The maximum length is 255 bytes.


variable <Jet definition>

variable

A named storage location that can contain data that can be modified during program execution. Each variable has a name that uniquely identifies it within its level of scope. A data type can be specified or not.

Variable names:

  • Must begin with an alphabetic character.
  • Cannot contain an embedded period or type-declaration character.
  • Must be unique within the same scope.
  • Must be no longer than 255 characters.


variance <Jet definition>

variance

The square of the standard deviation. It is a measure of the amount by which all values in a group vary from the average value of the group.


Variant data type <Jet definition>

Variant data type

A special data type that can contain numeric, string, or date data as well as the special values Empty and Null. The VarType function defines how the data in a Variant is treated. All variables become variant types if not explicitly declared as some other type.


variant expression <Jet definition>

variant expression

Any expression that can evaluate to numeric, string, or date data as well as the special values Empty and Null.


view <Jet definition>

view

View is the ANSI definition of a virtual table. A view is synonymous to a stored query in Access that is comprised of a SELECT statement without parameters. A view is a stored definition that is materialized at execution. It is different from a table in that it does not physically store any data. It returns data only.

A view can be created from the new ANSI SQL CREATE VIEW syntax exposed through the Microsoft® OLE DB Provider for Jet. Alternatively, a procedure can be created to allow for SQL DML statements and SELECT statements that have parameters. This can be done with the new CREATE PROCEDURE syntax exposed through the Microsoft OLE DB Provider for Jet.


wildcard characters <Jet definition>

wildcard characters

The asterisk (*), percent sign (%), question mark (?), underscore character (_), number sign (#), exclamation point (!), hyphen (-), and brackets ([ ]) are wildcard characters. You can use these characters in queries and expressions to include all records, file names, or other items that begin with specific characters or match a certain pattern. You can also use wildcard characters and matching characters to further refine a search when using an SQL statement.

Note The percent sign (%) and underscore character (_) wildcards are only used when using the Microsoft® OLE DB Provider for Jet. They are not exposed through DAO or the Microsoft Access UI. They will be treated as literal values in DAO or the Access UI.

Symbol | Example | Usage
* or % | wh* finds what, white, and why *at finds cat, bat, and what | Matches any number of characters, and can be used anywhere in the character string.
? or _ | b?ll finds ball, bell, and bill | Matches any single character.
# | 1#3 finds 103, 113, 123 | Matches any single digit.
[ ] | b[ae]ll finds ball and bell but not bill | Matches any single character within the brackets.
! | b[!ae]ll finds bill and bull but not bell or ball | Matches any character not in the list.
- | b[a-c]d finds bad, bbd, and bcd | Matches any one of a range of characters.

Note The wildcard characters * (asterisk), ? (question mark), # (number sign), and [ (opening bracket) can match themselves only if enclosed in brackets.


workgroup <Jet definition>

workgroup

A group of users in a multiuser environment who share data and the same workgroup information file (typically the System.mdw file).


workgroup administrator <Jet definition>

workgroup administrator

A member of the group Admins in a Microsoft® Jet database Workgroup object. A workgroup administrator can always obtain full permissions for any database object created in the Workgroup.


zero-length string <Jet definition>

zero-length string

A string containing no characters (""). The Len function of a zero-length string returns 0.


base computer <Jet definition>

base computer

A computer used in a star topology. A replica is copied from the hub server and placed on the base computer. This replica can be used to make additional replicas for other computers.

See Also
hub server star topology


conflict table <Jet definition>

conflict table

A table that is generated when a synchronization conflict occurs between two replicas. The conflict table appears only in the replica with rejected changes.


database replication <Jet definition>

database replication

The process of reproducing a database so that two or more copies (replicas) of the same database can stay synchronized. Changes to the data in a replicated table in one replica are sent and applied to the other replicas in the replica set. Changes made to the design of the database in the Design Master are sent and applied to all replicas in the set.


default synchronization partner <Jet definition>

default synchronization partner

A Synchronizer that is used to automatically synchronize a replica with other replicas in the set. When a replica is created, the Synchronizer managing the source replica becomes the default synchronization partner for the new replica.


default synchronization schedule <Jet definition>

default synchronization schedule

A template used by a Synchronizer to define a schedule between a newly managed replica and and its default synchronization partner, when the newly managed replica has no existing synchronization schedule. Once the schedule is defined, you can change the schedule.


Design Master <Jet definition>

Design Master

A database to which system tables, system fields, and replication properties have been added. A Design Master is the first replica in a replica set. You can make changes to the database structure only with the Design Master. Replicas in the same replica set can take turns being the Design Master, but there can be only one Design Master at a time in each replica set.


dropbox folder <Jet definition>

dropbox folder

The shared network location where a Synchronizer can leave or pick up design and data changes.


globally unique identifier (GUID) <Jet definition>

globally unique identifier (GUID)

A 16-byte field used to establish a unique identifier for replication. GUIDs are used extensively to identify replicas, replica sets, tables, records, and other objects.

Note In Microsoft® Access, GUIDs are referred to as Replication IDs.


hub server <Jet definition>

hub server

A computer used in a star topology. A replica residing on this computer can be used as a synchronization partner with other replicas.

See Also
base computer | star topology
satellite computer |


local object <Jet definition>

local object

A table or query that remains in the replica where it was created. Neither the object nor changes to the object are dispersed to other members in the replica set.


managed replicas <Jet definition>

managed replicas

A replica with an assigned Synchronizer. The Synchronizer delivers changes to and receives changes from other replicas in the set.

Note If you do not assign a Synchronizer to a replica, you can still synchronize it in your application's code or by using another Synchronizer. However, you cannot set synchronization schedules from this replica unless you assign a Synchronizer to the replica.


object replication <Jet definition>

object replication

The process of reproducing an object (table or query) so that two or more copies of the same object are synchronized. Changes made to the design of the object at the Design Master are sent and applied to all replicas in the set.


on-demand synchronization <Jet definition>

on-demand synchronization

The exchange of data between two replicas that occurs at the explicit request of the user.


replica <Jet definition>

replica

A copy of a database, including its tables, queries, forms, reports, macros, and modules. A replica is a member of a replica set and can be synchronized with other replicas in the set. Changes to the data in a replicated table in one replica are sent and applied to the other members in the replica set.

Note The Design Master is also a replica.


replicated database <Jet definition>

replicated database

A database to which additional tables, fields, and properties have been added to record information about changes to data and the design of replicated objects in the database.


replicated object <Jet definition>

replicated object

A table or query that is in all replicas in the replica set. You can change the replicated object only at the Design Master. These changes are then dispersed to other replicas in the replica set during a synchronization.


replica set <Jet definition>

replica set

Replicas that share the same database design and unique replica set identifier. Synchronization occurs between replica set members.


replica set member <Jet definition>

replica set member

A replica that belongs to a replica set. Members of a replica set share the same database design and can be synchronized with one another.


replicate <Jet definition>

replicate

Produce a replica, or copy, of something — for example, a database.


replication <Jet definition>

replication

The process of creating and synchronizing replicas in separate locations. Replication adds system fields, system tables, and replication properties to a database so that changes made to the data in or to the design of a database are sent and applied to all the members of the replica set.


Microsoft Replication Manager <Jet definition>

Microsoft Replication Manager

An application that provides a graphical user interface to manage the location, synchronization schedule, and relationship of one or more replicas with the other replicas in the set. Replication Manager manages the Synchronizer settings that govern replication, while the Synchronizer performs the actual synchronization activities. Replication Manager is part of the Microsoft® Office 97, Developer Edition.


retention period <Jet definition>

retention period

The number of days the system will retain certain replication system information for a replica. If the retention period expires before a replica is synchronized, the synchronization will fail.


satellite computer <Jet definition>

satellite computer

In a star topology, a computer on which a replica resides. This replica is copied from the base computer and synchronizes with a replica on the hub server by default.

See Also
base computer | star topology
hub server |


schedule <Jet definition>

schedule

The times when the Synchronizer will initiate synchronization with other replicas. The minimum increment of time between scheduled synchronizations is 15 minutes. You can set different schedules between any two Synchronizers.


scheduled synchronization <Jet definition>

scheduled synchronization

An exchange of data between two replicas that occurs at a predetermined time.


shared network folder <Jet definition>

shared network folder

See dropbox folder.


star topology <Jet definition>

star topology

A type of organizational map for networked computers. For replication, it refers to a hub server, base computer, and the distribution of members of the replica set on other satellite computers. Topology is important for determining synchronization schedules.

See Also
base computer | satellite computer
hub server |


synchronization conflict <Jet definition>

synchronization conflict

A situation in which users of two replicas have changed the same record. One of the updated records is selected as the "winner," and the record in the "losing" replica is updated to contain this data. The other updated record is placed in a conflict table in the losing replica.


synchronization error <Jet definition>

synchronization error

A problem that occurs during synchronization that prevents changes to a record from being completed successfully. This is more serious than a conflict and should be resolved as soon as possible.


synchronization <Jet definition>

synchronization

The process of updating two replicas in which all updated records and objects are exchanged. The exchange of data between two replicas can be one-way or two-way and may be handled by a Synchronizer.


replica set topology <Jet definition>

replica set topology

The order in which changes are propagated from replica to replica. Topology is important because it determines how quickly changes in another replica appear in your replica.


Synchronizer <Jet definition>

Synchronizer

A program that monitors changes to a replica and handles the actual exchange of data between replicas. The Synchronizer operates in the background and appears in the taskbar. You can see the Synchronizers for a replica set in the Synchronization window in Replication Manager.

Note The previous version of Replication Manager referred to Synchronizers as Transporters.


Synchronization window <Jet definition>

Synchronization window

The area of the Replication Manager where Synchronizers appear. You can move the Synchronizers, and zoom in or zoom out to see more or fewer Synchronizers. You can also click the line between two Synchronizers to edit their synchronization schedule. To understand the different icons in the Synchronization window, click Legend on the View menu.